Ayuda configurar IP Publica.



  • Hola, tengo la siguiente infraestructura...

    CABLEMODEM en modo Bridge... conectado al WAN de un router TP-Linky una PC conectada al router en los puertos LAN.

    en la pc si entro a www.cualesmiip.com me puestra una ip PUBLICA (lo mismo con el wifi) y puedo acceder del exterior sin problemas.


    Lo que quiero hacer es lo siguiente...:

    CABLEMODEM en modo Bridge... conectado al NIC1 de un servidor ProLiant DL20 G5 (con Pfsense)... en modo WAN.

    y un cable en el NIC2 al ethernet de mi PC....

    pero al hacer esto... cuando entro a cualesmiip.com me muestra una IP NAT Privada. y no puedo acceder desde el exterior.


    Alguien sabría decirme como solucionar esto?

    Mi idea es usar el ProLiant como router y eliminar el TP-Link (solo usarlo como ap de wifi)



  • ¿Ya conversaste con el ISP si te entrega una IP Pública o privada y si es fija o dinamica?

    Si es un cable modem pero NO router, quién te lo configuró como bridge? y podrías explicar qué IP le pusiste en la WAN al servidor?

    Escribes de un servidor HP ProLiant DL20 G5 y al igual que otras intervenciones que he tenido sobre servidores HP, no soporta de forma nativa pfSense y en el enlace del producto te dice lo que si soporta. Así que mi pregunta respecto a esto seria. ¿Tenes instalado pfSense sobre un sistema operativo para virtualizar o como? Esto es importante para responderte.

    Aclara por favor esos datos, porque si realmente ese servidor HP tiene instalado solamente pfSense, la wan debería quedar exactamente igual la configuración del TP-Link.



  • Hola Brujo, muchas gracias por responder... paso a solventar los cabos sueltos que deje.

    Mi ISP me da una ip privada (nat) si uso el cablemodem como modem y router (con wifi)...

    Si quiero una IP Publica... debo ponerlo en modo bridge (lo puedo hacer yo desde el mismo panel del router... ) y usar un router aparte (en este caso el tp-link).

    Aclaración: yo en estos momentos teniendo el cablemodem en modo bridge... y el router tplink... tengo ip publica y puedo acceder desde fuera (de hecho tengo un CWP en mi pc... con unos pares de dominios funcionando del exterior sin problema).

    En cuanto a lo del servidor, me comi un numero... es un ProLiant DL320 G5.

    Lo instale directamente como sistema operativo, no esta virtualizado!

    Cabe aclarar... que si conecto mi pc de escritorio con windows, directo al cablemodem (en modo bridge y sin el router tplink) me asigna una ip privada nat...

    Solo tengo la ip publica si conecto el router de tp-link al cablemodem y aqui es donde me explota la cabeza.

    A mi pensar, al conectar el pfsense directo al cablemodem, deberia darme la ip publica como si fuere el tplink, pero no sucede eso.

    PD: La IP es pseudo dinamica, cambia una vez cada muuuucho tiempo.


  • Rebel Alliance



  • Ya estas respondiendo que el ISP te da una IP privada la cual le aplicó reglas NAT en sus equipos para que salieras al exterior. Así que no es del todo pública, pero es lo que te da el ISP donde tiene que pasar por sus equipos, según como lo estas explicando.

    Al poner un dispositivo en modo bridge, este ni siquiera asigna IP y decis que cuando conectas un computadora, te asigna una IP, o sea, no está para nada en bridge y lo que tenes es un cable-modem/router.

    Con el servidor, para poder instalar pfSense, supongo que en el BIOS desactivaste la tarjeta de arreglo y ve el o los discos del servidor en modo simple.

    A mi parecer, no es asunto de clonar MAC, sino de asignar a la tarjeta WAN del pfSense una ip fija para que pueda trabajar bien.

    Tu problema es más que todo configuración de esquema de red y conceptos.

    Sería conveniente que colocaras tu diseño de red y la configuración de red en cada punto.

    Saludos y seguimos.



  • Hola ptt, hice eso y al conectar me asigna otra ip pero sigue siendo privada... si saco todo y conecto el router y conecto una pc ahi... sigo teniendo la ip publica.

    brujo, la ip es privada solamente si tengo el cable-modem/router en modo router...

    pero si lo pongo en modo bridge ellos me dan ip publica.

    Reitero... yo actualmente teniendo el cable-modem/router en modo bridge y el router tp-link.... tengo una ip publica y puedo acceder desde el exterior.

    Ahora volvere a probar con una instalación limpia y hacer el diagrama y lo subo a ver en que estoy fallando.

    En cuanto al servidor, en el DL380 G5 tengo el ProxMox para controlar las maquinas virtuales... y en el DL320 G5 simplemente instale el pfsense y funcionó... no tuve que hacer nada... lo único que hice fue actualizar los bios nomas.

    Por otra parte, conectando todo como lo estoy haciendo, tambien puedo navegar por internet tanto en el servidor haciendo ping o en otra pc cualquiera que conecte en el NIC2... sin problema alguno... solo que se me asigna una ip WAN privada... esto es lo que no entiendo porque.. si se supone que el pfsense debería reemplazar al tp-link en teoría


  • Rebel Alliance

    Y cómo sabe/determina tu ISP que tienes conectado un "Router" y le asigna/entrega IP Pública en lugar de IP privada ?



  • pues, ahi ya no se... el porque me hace eso con el pfsense y no con el router, obviamente es algo de configuración.

    lo que si se es que si pones el cable-modem/router en modo bridge... y pones un router comun usas el dhcp del router, el wifi del router ademas de poder manejar los puertos... ya que el cable-modem/router de la ISP es un Technicolor malisimo que no deja configurar nada.

    lo unico que se es que tengo servicios funcionando en este preciso momento con el tp-link de por medio 🙄 y estoy necesitando para una de las maquinas virtuales un par de configuraciones que no puedo con el tp-link trucho que tengo 🤕


  • Rebel Alliance

    @KatiaSisHost said in Ayuda configurar IP Publica.:

    pues, ahi ya no se... el porque me hace eso con el pfsense y no con el router, obviamente es algo de configuración.

    Cómo configuras la WAN del TP-Link ?

    Cómo configuras la WAN del pfSense ? (capturas de pantalla)

    https://forum.netgate.com/topic/21817/recomendaciones-al-postear



  • @ptt said in Ayuda configurar IP Publica.:

    Y si "clonas la MAC" del TP-Link ?

    --> https://docs.netgate.com/pfsense/en/latest/interfaces/interface-settings.html?highlight=mac#mac-spoofing

    Buenas, ayer misteriosamente llegue a casa lo hice y funcionó a la primera... aunque esto ya lo habia intentado antes.

    Aún me queda la duda de que es lo que pasó... quizas tipear algo mal... aunque lo hice varias veces, la verdad... aun sigo sin saber que es lo que paso.

    Muchisimas gracias a todos <3


Log in to reply