[SOLVED] wireless AP and pfSense, seperate subnets



  • ok so i have my wired network, which uses a 4 port switched gigabit card, and a 48 port 10/100 switch with gigabit uplink. now i am adding wireless AP's, they will be connected on separate wired network cards. i have set this up, enabled DHCP on the nic attached to my wireless AP (only one right now until its working). just for testing there is a blanket rule in my rules allowing all traffic on that interface, this will change once its working properly.
    on my wired network i have 192.168.1.1/24, so leased ips range from 192.168.1.0->192.168.1.255
    on my wireless nic i have 192.168.2.1/24 , so same deal but with 2 instead of 1.

    i connect to my wireless ap, and am leased an IP which i expect  (192.168.2.xxx)
    however i can not access any resources, no internet, no network resources, i can not even access the router settings.
    is there a setting i have missed at first i thought i just needed rules to say that its ok for it to access things, but the blanket rule on that interface should allow any traffic.

    please let me know what you think about this, if you need any information or screenshots let me know, i just did not take screenshots because ithe computer im on isn't capable of taking screenshots without 3rd party software, but i can do it if needed.

    thanks in advance everyone :)
    kyle

    [SOLVED]
    so i noticed if i was wired into my wireless router (which was supposed to act like an AP) then it worked fine, but wireless into that same router, nothing. then i manually assigned my ip and suddenly it worked! What was weird tho is i assigned manually the exact same information that the DHCP server was giving? EXACTLY the same information. either way, i just fiddled with some settings, turns out my DHCP lease range was 192.168.2.0->192.168.2.250, changed it to 2.100->2.199

    reconnected with DHCP, works perfect


Log in to reply