Cannot set Switch Port for multiple VLANs



  • I am trying to set up 2 VLANs on pfSense 2.4.5-RELEASE-p1. I am using only LAN 1 port on my SG-3100.
    I am new to VLANs but not to pfSense.
    If I set the Switch Port In the Interface/VLAN20 to Port 1 then I cannot set it as the same in the Interface/VLAN30.VLAN20_Interface.png
    Why is this? Should I leave it blank?



  • @TheMetMan said in Cannot set Switch Port for multiple VLANs:

    If I set the Switch Port In the Interface/VLAN20 to Port 1 then I cannot set it as the same in the Interface/VLAN30.

    When you use VLANs, they have to match everywhere. For example I use VLAN3 for my guest WiFi. I configured VLAN3 on pfsense, on the switch ports going to pfsence & the AP and again on the AP. The reason for this is the source creates a VLAN tag. All the other devices then read the tag, to see if it's for their VLAN.



  • @JKnott I understand that.
    What is confusing me, and I think is stopping the VLAN working is the Switch port.
    I have put a switch lead into port 2 on the SG-3100 and set the 'Switch port' to Port 2, but it still does not connect to the VLAN.
    The problem is I plan to have 3 switches connecting to the SG-3100 all with various VLANs so I cannot set, for instance, VLAN20 to monitor Ports 1, 2 and 3.
    I just cannot see why my Laptop plugged into a switch will not connect to a VLAN.



  • @TheMetMan said in Cannot set Switch Port for multiple VLANs:

    'Switch port' to Port 2

    What do you mean by 'Switch port' to Port 2? You add VLANs to the switch ports as needed. Every port where you need VLAN20, you add it, etc..



  • @JKnott If you look at the image above, I have highlighted the 'Switch port' setting.
    I have VLAN20 and VLAN30 on the mvneta1 interface. Then SG-3100 has 4 LAN ports, but I would like to only use one of these.
    What I am asking is do I just leave this setting as is shown in the screenshot?



  • @TheMetMan

    The highlighted part refers to media change, are you worried about it changing? Also, I don't even see that here. How did you manage it?

    Why is this? Should I leave it blank?

    Read the note underneath. On my system it says If this interface is an Internet connection, select an existing Gateway from the list or add a new one using the "Add" button. On local area network interfaces the upstream gateway should be "none". Gateways can be managed by clicking here. Is this a WAN port? If not, you leave it at none.



  • @JKnott OK, thanks I understand that now. I do not have any media to change so 'Switch port' can be left alone.
    As for the section below, and looking at the pfSense Book, I don't think I need to add a gateway.
    Thanks very much for your input.


Log in to reply