Troubleshooting VLAN Connection



  • I cannot get a VLAN connection working. I have looked at several posts here, and elsewhere. I have read the pfSense Book on VLAN Setup and many posts and manuals on setting up my 8 port TP-Link Easy Smart Switch.
    I am new to VLANs but not to pfSense.
    I am pretty sure I have everything setup correctly, but I cannot connect.
    I am running an SG-3100 Router with pfSense 2.4.5-RELEASE-p1.
    To simplify things I will just talk about the following:
    WAN is on mvneta2 connected to my ISP’s Router,
    LAN is on mvneta1 10.6.77.0/24
    VLAN20 is on mvneta1 as 10.0.20.0/24
    VLAN30 is on mvneta1 as 10.0.30.0/24
    VLAN20_Interface-Plain.png
    Here is the DHCP:
    VLAN20_DHCP.png
    For the NAT I clicked Manual, saved it and then Clicked Automatic again and saved it.
    For Rules to begin with I just allowed everything:
    Rules_VLAN20.png

    My Switch is setup like this:
    8PortSwitch.png
    And Port 1 is plugged into LAN2 on the SG-3100

    If I plug my laptop (running Gentoo Linux) into port 6 which is not on any VLAN on the switch I can connect with DHCP and get the normal address 10.6.77.11
    If I plug in to port 7 then it is unable to connect.

    I have tried rebooting the SG-3100 but no difference.
    I can ping VLAN20 10.0.20.1 from the LAN and pfSense.
    There are no packets showing at all when I try and capture packets in the VLAN20 Interface and attempt to connect.

    What can I look at to find the cause of being unable to connect to VLAN20?

    Thanks in advance.



  • SOLVED it myself in the end!!!
    For anyone else out there with the same problem.......
    It was Enable 802.1q VLAN mode in the Switch Settings on the SG-3100.

    Interfaces->Switch->VLANS
    

    I unchecked this so it was using Port Mode, left it at the default, and I can now connect.


Log in to reply