E2Guardian nao bloqueia acessos por APP celular


  • Boa tarde companheiros, instalei o E2Guardian seguindo os tutorias de nosso grande mestre @marcelloc no qual esta rodando bem, fazendo o bloqueio http e https nos computadores. Porem em celulares os app de facebook, instagram entre outros esta passando normalmente, e se eu for no Real time conta que o ip dos dispositivos moveis, os sites sendo como bloqueados. Mais nao bloqueia. Alguem ja passou por isso e pode me ajudar? Desde ja obrigado a todos


  • Olá @hugolrb,

    Se no realtime está sendo bloqueando pelo E2G, o mesmo está fazendo o trabalho correto de bloqueio conforme os filtros definidos e aplicados por você para redes sociais.

    Verifique se não tem algumas das situações abaixo:

    1- Verifique se os celulares que estão acessando o facebook está com o dados móveis ativo. Caso sim desligue e só deixe o do wi-fi ativo para validar essa situação.

    2- Verifique nas regras da interface Lan se possa ter alguma regra acima de forçar a passagem pelas portas 8080 e 8081 do E2G. Caso identifique alguma brecha de saída desabilite ela para validar os filtros de bloqueios também a nível de firewall.

    Atenciosamente.

    César Moura


  • @acamoura ok meu amigo vou verificar e posto o resultado


  • @hugolrb tudo certo?
    Estou com o mesmo problema aqui faz mais ou menos 2 semanas e não consigo resolver, já verifiquei os itens citados pelo amigo @acamoura mas mesmo assim não resolveu.

    Você conseguiu resolver ou avançar ?

    Obrigado.


  • Olá @acamoura, tudo certo?

    Primeiramente peço desculpa por "invadir" o post, mas estou com esse problema relatado pelo @hugolrb e não consegui resolver também, fiz estes testes ai que você comentou no post mas o resultado foi o mesmo, está mostrando como bloqueado no real time mas mesmo assim passa nos APPS do celular.
    Estou achando que seja algo na blacklist que o e2g utiliza.

    Você já passou por algo assim, tem alguma outra dica ?

    Agradeço.


  • Olá @evandro-trebien,

    O seu E2guardian está rodando como proxy transparent e com inspeção SSL ativo? Se sim.

    Você já verificou se a sua acls default está ativada bloqueando a categoria rede social?

    0e3efb5b-ce00-4205-a4fa-bf73dda0f342-image.png

    Atenciosamente.

    César Moura


  • @acamoura acabei de verificar estes itens e estão configurados desta maneira.
    Refiz um ambiente físico de testes em um link secundário/server que possuo aqui e tive o mesmo problema.

    Problema: socialnet domais aparecem como bloqueados no realtime mas no celular passa.

    OBS: Já conferi pra ver se a ACL estava para rodar sempre, conferi horário do servidor também pois tenho uma regra pra horário de intervalo, refiz as regras de LAN pra ter certeza que nada estava sobrepondo e certifiquei que os celulares estivessem sem rede moveis.

    Segue um print de algumas telas da minha config aqui. [Sem título.png


  • @evandro-trebien,

    Os celulares que se conectam em sua rede via wi-fi, esse dispositivo está em bridge ou ele está setado um IP da sua rede LAN?

    Caso ele esteja com IP Fixado e assim estiver setado IP da sua rede LAN no dispositivo wi-fi (roteador / access point) verifique as suas regras de firewall na interface da LAN se este IP está liberado. Isso poderia ser um indício dos celulares estarem conseguindo ter acesso as redes sociais.

    Atenciosamente.

    César Moura


  • @acamoura a configuração que tenho aqui é uma rede LAN(DHCP ENABLE), os roteadores são conectados em modo bridge(COM DHCP desabilitado) nessa LAN, obtendo assim o
    IP diretamente do servidor DHCP do firewall. Utilizo os roteadores ubiquitis aqui.

    Segue minhas configurações da LAN.

    lan.PNG

    OBS: Utilizo o e2g nas portas 1980 e 1981.
    Pfsense versão 2.4-5
    e2g versão 0.5.3.4

    O estranho é que montei um ambiente do zero, fora desta rede aqui, somente com um roteador e 2 dispositivos conectados e o erro é o mesmo.

    Por isso estou quebrando a cabeça pra encontrar qual o erro.

    Realtime: Capturar.PNG


  • Olá @evandro-trebien,

    Após uma instalação padrão do pfSense as suas regras conforme printadas abaixo estão desativadas, pois elas vêm como default ativas e assim é liberado tudo na interface LAN. Esse poderia ser outro indicio que esteja acessando.

    e3a0425d-7ef1-4107-ba26-e902cb6a2ff1-image.png

    Eu sempre desabilito elas para realmente ter uma boa forma de controlar e liberar somente oque precisa de trafegar e o resto fica tudo bloqueado.

    Atenciosamente.

    César Moura


  • @acamoura Certo, mais quando ja chega ness etapa quer dizer que ja passou pelo e2g e agora ja ta saindo da LAN pra WAN. O caso em questão é: Porque o real time esta constando com block mais passa? Eu creio que pode ser uma questão de ips, pois a rede face e insta pelo que sei esta usando o mesmo range de ips que o whats, dai como whats é liberado os outros tambem sao. Posso estar errado mais é minha linha de raciocínio.
    Ja estou pensando em usar o snort pra tentar bloquear