Bypass squidguard for IP addresses - can't set exception?



  • I've been running pfSense as my firewall since June, but until yesterday just using transparent proxy. All was fine.

    Then I set one of my PC's to use Squid proxy on port 3128, and started testing all the bookmarks I commonly use. There were a few sites where I had to request it twice to get it to download, but generally all was fine.

    Until I tried to look at my cable modem status.

    Cable modems - at least mine - use IP address 192.168.100.1. Squid/squidguard blocks this.

    And I cannot find a way to add an exception to whitelist an IP address. I have the option set to not allow IP addresses in place of URL's, and I'm thinking this is the cause.

    Is this correct? I cannot exempt/whitelist an IP address? I have to throw the baby out with the bathwater by allowing people to bypass all squidguard ACL's with IP addresses?

    I'm not keen on having to add a DNS entry for my own cable modem just to look at it through pfSense.

    CJ


Log in to reply