Torrents not working when using proxy



  • Just switched over to pfSense from a dinky netgear router, and most all configurations are set at defaults. Nothing too fancy going on here. Everything is allowed out, nothing is allowed in, Outbound NAT is set to "Automatic", and UPnP is disabled. I am not using any network shaping services.

    Prior to switching over, uTorrent+SOCKS5 proxy/vpn worked as expected.

    Now after switching, uTorrent+SOCKS5 (1080) or HTTP (80) proxy/vpn does not work. Unable to torrent at all.

    If I do not use a proxy, torrenting sort of works where I am able to download, but upload/seeding does not work.

    Oddly enough, if I start the torrent with no proxy and get some peers, if I stop the torrent, change it to use HTTP proxy (SOCKS5 still doesn't work), the torrent is able to download still (but not upload).

    If I enable the VPN application on my computer where all connections go through VPN, including torrents, torrents again work in a download only direction.

    I am not looking to add a VPN service within pfSense.

    I tried enabling UPnP to see if that would do anything, but no change.

    A) What would cause torrents to only work in a download direction?
    B) Why do torrents sort of work when a whole interface VPN is used, but not when the built-in proxy is used?

    What can I look at / attempt to do to enable torrenting?

    Thanks.



  • Hmmm, a bit more fiddling around today.

    I tried some port forward stuff as well, but didn't work.

    Though, I suppose this is a false alarm on the pfsense side of things.

    I disabled my windows firewall (private inbound to allow all) and it works as expected.

    I'll have to figure out what specifically is blocking it there then, not sure why in that regard it would have changed.



  • And now for no inexplicable reason with the windows firewall back on the block connections, everything is working perfectly, seeding and all.

    Wonder if there was just some wonkyness with the ISP going on. The ISP modem is/was in bridge mode (a surfboard model that only supports bridge mode) so I wonder if somehow the ISP saw a different device downstream of that (netgate box instead of netgear) and was doing something wierd.

    Guess we'll see how it goes, and if this crops up again..



  • Still must have been something cached. Now that I am able to replicate the issue, the only thing that works is setting up port forward. I did a generic any any, so i'll need to figure out what specifically needs to be done.

    I'm still not sure I understand why torrents would work while a whole client vpn is in use with no proxy, versus no whole client vpn with SOCKS5 proxy.


Log in to reply