GEO-IP not logging



  • Just curious if anyone has ran into this before. I'm on pfSense 2.4.5 and pfBlockerNG 2.1.4_22. All at latest stable from what I can tell.

    It's been awhile since I've cared about the geo_ip data but coming back to it, I'm not seeing anything being logged in the firewall filter.log nor a geo_ip or similar log file in the /var/log/pfblockerng folder. In fact, I don't even have an geo-ip/ip_block log file in that folder.

    I've tried forcing a reload from the UI and command-line, changing the maxmind key, going from floating to wan and back again rules, enabling and disabling global logging, etc.

    pfBlockerNG logs just fine for DNSBL as well as all the other files. Interestingly, my alerts tab is working fine as is the pfblockerng dashboard widget to show the blocks.

    Apart from doing an uninstall/reinstall, does anyone have any suggestions?



  • @llebgrate said in GEO-IP not logging:

    I'm on pfSense 2.4.5 and pfBlockerNG 2.1.4_22.

    Hi,

    a quick override....😉

    1. pfSense actual version is: 2.4.5-p1
    2. pfBlockerNG-devel: 2.2.5_34

    +++edit:
    the maintainer's @BBcan177 suggestion is the -devel version, this version is actively developed

    don't be afraid of the word DEVEL it's just a word 😉

    547b9ce5-9a41-4cb8-b352-ddbb621a8fde-image.png

    so it works well



  • Fixed. Thanks.

    I've been riding the lazy update/upgrades w/out checking the latest packages. New package works great, ty!



  • @llebgrate said in GEO-IP not logging:

    Fixed. Thanks.

    You Welcome 😉


Log in to reply