Console / Installation Auflösung



  • Hallo Zusammen

    Ich habe einen DELL 4k Monitor, wo ich einen Minicomputer für die PFSense Installation angeschlossen habe.
    Leider rutscht mir der Text ganz unten etwas unter den Bildschirmbereich, so dass man die letzte Zeile nur etwa zu einem Drittel sieht. Und natürlich sieht man auch nicht was man eingibt.

    Viele Lösungsansätze hatte ich via Google gefunden.
    Doch möchte ich den Bootloader nicht anpassen.

    Ich hatte sogar eine Möglichkeit gefunden, den Wert (MODE) zu ändern durch eine Auswahl. Leider finde ich diese Lösung nicht mehr.
    Kann mir da jemand weiter helfen?

    Vielen Dank



  • Hallo,

    @Mansaylon said in Console / Installation Auflösung:

    Doch möchte ich den Bootloader nicht anpassen.

    ich kenne nun keine Lösung, aber sollte es welche auf Seiten der pfSense geben, wirst du da nicht herumkommen.

    Du kannst die Einstellung in die /boot/loader.conf.local schreiben, diese ist im Gegensatz zur loader.conf reboot- und upgrade-resistent.



  • Ist schon zum verzweifeln, dass ich die Lösung zum Umschalten nicht mehr gefunden habe.

    Welcher Editor ausser VI gibt es noch in pfSense ?
    Und habe ich das richtig gesehen.... loader.conf.local muss man selber erstellen?



  • @Mansaylon said in Console / Installation Auflösung:

    Welcher Editor ausser VI gibt es noch in pfSense ?

    Teilst du meine Abneigung gegen VI? 😁
    Einen anderen müsstest du aber vermutlich erst installieren. Habe ich nicht gemacht.

    Ja, die /boot/loader.conf.local existiert nicht von Haus aus und muss erst erstellt werden.

    Kommst du noch nicht auf die GUI?
    Diagnostics > Edit File
    Damit wäre die Sache easy.

    Anderenfalls kannst du ja die loader.conf.local auch direkt in der Shell erstellen und befüllen:

    echo "Parameter=\"Wert\"" >> /boot/loader.conf.local
    

    Die Anführungszeichen müssen escaped werden, so dass am Ende

    Parameter="Wert"
    

    im File steht.

    Wenn du die Eingabezeile nicht siehst, könnte sich das aber auch als schwierig gestalten.



  • :-) Ja der VI ist wirklich aus dem letzten Jahrtausend.... damals als man noch mit Akustikkoppler unterwegs war.

    Das mit 'in der Shell erstellen' ist eben so das packende Problem... da ich ja nicht sehe, was ich eingebe (unterste Zeile ist unterhalb des Bildschirmes).... war ja auch der Grund für meinen Thread ;)
    Etwas in der Shell eingeben, kann man sich so vorstellen, als wäre der Bildschirm einfach ausgeschaltet. Dazu kommt noch, dass in der Shell das US-Keyboard gültig ist und ich eine Schweizer Tastatur habe (obwohl ich bei der Installation die richtige Tastatur angegeben hatte).

    Versuchte auch mal über das Bios den Boot-Vorgang über UEFI auszuschalten... bootete dann einfach nicht mehr.



  • Die GUI erreichst du also noch nicht.

    @Mansaylon said in Console / Installation Auflösung:

    Dazu kommt noch, dass in der Shell das US-Keyboard gültig ist und ich eine Schweizer Tastatur habe (obwohl ich bei der Installation die richtige Tastatur angegeben hatte).

    Das Problem kenne ich.
    Ich würde es aber dennoch damit versuchen. Ein passendes US Tasturlayout sollte im Netz zu finden sein. Dann weißt du, welche Taste du benötigst.
    Im Grunde geht es ja nur um die beiden Zeichen ">" und "", die anderen Tasten zugeordnet sind, jedenfalls entgegen dem deutschen Layout.

    VI wäre da wohl auch keine große Hilfe, denn die einzige Zeile im File steht AFAIK auch ganz unten.

    @Mansaylon said in Console / Installation Auflösung:

    Versuchte auch mal über das Bios den Boot-Vorgang über UEFI auszuschalten... bootete dann einfach nicht mehr.

    Soweit ich weiß, erfordert das eine Neuinstallation.
    Das könnte aber auch die Lösung für das Anzeigeproblem sein.


Log in to reply