Could not locate the CA reference for the server certificate. Failed to export config files!



  • Good afternoon from the West Coast all,
    On my client's 2.4.5-RELEASE-p1 (amd64) running on esxi 6.0 I had to remove the original local CA (on-box) and create new. After I did that I deleted recreated all the user certificates and the road warrior VPN and associated server cert. With that done when I try to export an Ovpn user package/config I get the following;

    The following input errors were detected:
    Could not locate the CA reference for the server certificate.
    Failed to export config files!

    Nothing to speak of in the system or Ovpn logs. Is this a known bug? Remote access to their site is currently down due to this. Thanks all. -W



  • Anyone...Bueler......Bueler?


  • LAYER 8 Rebel Alliance

    Good afternoon from Germany.
    I tried to reproduce this in my lab but it's working as expected. Are you running the latest openvpn-client-export package (1.4.23_2)?
    Can you post the CA and Certificates tab and OpenVPN server config (screenshots)?

    -Rico


  • LAYER 8 Rebel Alliance

    Okay I managed to provoke exactly your error with setting the OpenVPN server cert to the WebConfiguratior cert, then tried to export the User config.
    pfSense_Cert_Error.png
    Sooo there is something messed up with your Server Cert or you have a wrong cert configured in the OpenVPN server setting.

    -Rico



  • Thanks for labing this up. So what else can I do aside from creating a new local CA, generating new server and user certs + multiple reboots?



  • Oh yes and I did update the client export package to the latest and no love.


  • LAYER 8 Rebel Alliance

    You need to have the same CA as Issuer for the Server and Client Cert.

    -Rico


Log in to reply