Comunicar duas redes em mesmo ambiente


  • @DAF No windows, você pode olhar as propriedades da conexão do lado do relógio, ou pode digitar ipconfig no prompt.
    No Linux, ifconfig ou ip address (depende da distribuição).

    Lá, deverá constar o IP da interface do pfsense, na parte de gateway.
    Conforme seu primeiro post, deverá ser 192.168.1.1 para LAN e 192.168.2.1 para LAN1


  • @mcury Sim eu setei manualmente na maquina com lan2 o endereço 192.168.20.100
    Masc 255.255.255.0
    Gateway 192.168.10.254
    OBS: mesmo liberando todos os protocolos nao tem navegação de internet

    Na maquina com a Lan1 ele pegou automaticamente o seguinte endereço
    192.168.10.10
    255.255.255.0
    192.168.10.254


  • @DAF Não entendi, seu primeiro post dizia:

    WAN (link intenet)
    LAN 192.168.1.1 (Computadores e Notebooks)
    LAN1 192.168.2.1 (Impressoras e Telefones Voip)

    Você pôs um IP 192.168.20.X e 192.168.10.X nas maquinas?
    Esses endereços não fazem parte da mesma rede onde a interface do pfsense está.


  • Desculpe a confusao, foi erro de digitação
    segue corrigido
    WAN (link intenet)
    LAN 192.168.10.254 (Computadores e Notebooks)
    LAN1 192.168.20.254 (Impressoras e Telefones Voip)

    Maquina 1 na LAN endereço setado automaticamente
    192.168.10.10
    255.255.255.0
    192.168.10.254
    (maquina navega na internet)

    Maquina 2 na LAN1 endereço setado manualmente
    192.168.20.101
    255.255.255.0
    192.168.10.254
    (maquina nao tem navegação de internet)


  • @DAF Perfeito, está correto então a parte de gateway.
    Confirme se existem regras de firewall na interface LAN1, permitindo acesso a any, que seria a Internet.
    Qualquer dúvida você pode comparar as regras que tem na LAN para replicá-las na LAN1.

    Confira se exista NAT de saída para a LAN1, vá na aba NAT e confirme.


  • @mcury em NAT so ha esta regra ![alt text](fw.JPG image url)


  • @DAF O NAT está correto, observe que as duas rede estão ali, tanto a 192.168.10.0/24, quanto a 192.168.20.0/24.
    O problema é regra de firewall, ou DNS que não está configurado nas máquinas da LAN1.

    Confirme se tem regra de firewall permitindo a saída la na LAN1.
    E confirme se as máquinas da LAN1 tem DNS configurado.



  • O default gateway do computador 192.168.20.101 não pode ser 192.168.10.254.

    Nessa imagem, altere o default gateway para 192.168.20.254 e o DNS para 192.168.20.254 e teste novamente.


  • @mcury fw4.JPG
    Sem sucesso


  • Agora está certo, uma coisa que você não fez, foi criar regras de firewall, certo?
    Vá lá em Firewall>Rules>Lan1 e crie uma regra igual tem na Lan


  • @mcury fw5.JPG
    Eu havia criado estas duas


  • Está certo, pode apagar a segunda regra.
    Abre o prompt e digita: ping 192.168.20.254 e confirma se há resposta
    ping 8.8.8.8 para testar também.

    Me confirma se na aba do DNS Resolver como na figura abaixo, a interface LAN1 está marcada lá em network interfaces

    496c642f-d3bd-4082-8796-19ab388a4882-image.png


  • @mcury fw6.JPG segue o ping a partir da propria maquina em LAN1


  • @mcury fw7.JPG Ao selecionar as duas interfaces e mandar salvar apresenta erro


  • @DAF Acho que você tem um problema de cabos aí.
    Essa máquina está com o cabo direto na placa LAN1, ou tem um switch no caminho?
    Dá uma conferida nos cabos e no switch, pois você não consegue pingar nem a interface LAN1 do pfsense.

    Em relação ao erro da sua última mensagem, deixe network interfaces em ALL, ou selecione LAN, LAN1 e Localhost


  • @mcury Engraçado que da Lan eu consigo pingar LAN1 mas o contrario nao

    Sera que tudo isso é pq estou em maquina virtual


  • @DAF Pode ser, conecte um computador na LAN1 (que não seja uma VM), e teste.
    Se funcionar, é alguma configuração na VM.

    Lembrando que se você se conectar na LAN, o IP da máquina deverá fazer parte da LAN (192.168.10.0/24)
    O mesmo serve para LAN1, se conectar o computador lá, ele deverá fazer parte da LAN1 (192.168.20.0/24)


  • @mcury Obrigado pela sua atenção. Amanha vou fazer este teste


  • @DAF blz, se estiver tudo conectado certinho, digo fisicamente, o teste vai funcionar, vai conseguir pingar o pfsense e acessar a internet.
    Se não funcionar, eu verificaria se a interface LAN1 do pfsense está UP, lá em status interfaces.
    Depois verificaria cabos e switch.