Captive Portal connected, but can't access internet


  • Hi everybody!
    I have a Captive portal on Vlan and it's been stable for about 2 weeks, today user connected, but can't access internet, while devices with Mac add (captive portal \ Mac) still access the internet. I restarted pfsense to use it, but I don't know what the cause is yet. Can someone help me!!!!

    Thanks you!!


  • Hi,

    @chicongdhv said in Captive Portal connected, but can't access internet:

    but I don't know what the cause is yet.

    Known issue.
    When you modify the settings of the captive portal, the 'ipfw' firewall rules with the authenticated users gets flushed.
    The users that have their MAC listed in the rules is getting restored, so they are not affected.

    See Troubleshooting Captive Portal for yourself. Have a user log in (authenticate), see the rules and tables, modify portal settings and check again the rules and tables.

    The issue is : the database with connected uses still lists all the connected users, so pfSense 'thinks' that already authenticated users are still logged in, won't get redirected to the portal login page, and just see a simple line "You are already connected".

    You have 3 options :

    1. Do not edit portal settings wile users are logged in.
    2. If you have to edit the settings, flush all the connected users. > Status > Captive Portal > ZONE and hit rthe red button.
    3. Install the patch pfSense package, look up the patch, as it is mentioned many times in this part of the forum, and install the patch. You'll also find instructions how to do so.

  • Thanks @Gertjan , but, I not edit the install Captive portal, when I leave between time work and back to back, it all all people disconnected internetl


  • @chicongdhv

    You see the clients connected in the StatusCaptive Portal page, but when you use the ipfw command (see link above) there are no connected user ?

    Use

    ipfw table all list
    

    and list what are in these tables :

    --- table(cpzone1_auth_up), set(0) ---

    --- table(cpzone1_auth_down), set(0) ---