pfBlockerNG DNSBL service pare che non funzioni


  • Ciao,
    Ho avviato pfsense e vedo che il pfBlockerNG DNSBL service non è avviato:

    alt text

    Qualcuno può aiutarmi a capirne il motivo e a risolvere?
    Grazie

  • LAYER 8

    @senseiluke
    prova a farlo partire manualmente e poi controlla i log per capirne il motivo
    funziona solo se dns resolver è attivo, non funziona con dns forwarder


  • @kiokoman said in pfBlockerNG DNSBL service pare che non funzioni:

    @senseiluke
    prova a farlo partire manualmente e poi controlla i log per capirne il motivo
    funziona solo se dns resolver è attivo, non funziona con dns forwarder

    Solo con il resolver? Accidenti allora deve essere questo il problema.
    Non ho capito perché il resolver non vuole funzionare dopo che ho riprisitnato la VM pfsense su Proxmox? Su 3/4 volte che ho installto pfsense mi sono ritrovato con il problema del resolver non funzionante la metà delle volte e ho dovuto switchare al forwarder.
    Mai capito la causa.
    Grazie e buon anno

  • LAYER 8

    @senseiluke
    purtroppo si funziona solo con resolver, infatti per partire quel servizio aggiunge in automatico delle direttiva sotto "custom option" del resolver. quindi se non parte resolver non parte neanche pfb_dnsbl


  • @kiokoman said in pfBlockerNG DNSBL service pare che non funzioni:

    @senseiluke
    purtroppo si funziona solo con resolver, infatti per partire quel servizio aggiunge in automatico delle direttiva sotto "custom option" del resolver. quindi se non parte resolver non parte neanche pfb_dnsbl

    Capito.
    Una curiosità. Ho dato uno sguardo nel resolver alle custom option:
    alt text

    Al momento naturalmente non ci sono direttive. ma nel caso in cui riuscissi a far funzionare il resolver e ad avviarlo, pfBlockerNG inserirebbe automaticamente quelle direttive o dovrei reinstallare pfBlockerNG da capo?

  • LAYER 8

    @senseiluke
    non saprei, non lo uso e può essere che nel frattempo qualcosa sia cambiato e la direttiva li non sia più necessaria, prova a leggere qui https://forum.netgate.com/post/947354


  • @kiokoman
    ok grazie


  • @senseiluke pfblocker funziona in due modalità:

    1. Blocco del traffico tramite regole di firewall;
    2. blocco del traffico tramite risoluzione dns;
      Sono modalità indipendenti e vanno configurate ed attivate. Di base il controllo tramite dns è disattivato quindi se non lo configuri vedrai il servizio arrestato.
      Come ti hanno già indicato ha bisogno del motore del resolver per funzionare.
      Probabilmente il resolver non lo hai configurato correttamente, per questo spesso non ti funziona.
      Ciao Fabio

  • @fabio-vigano said in pfBlockerNG DNSBL service pare che non funzioni:

    @senseiluke pfblocker funziona in due modalità:

    1. Blocco del traffico tramite regole di firewall;
    2. blocco del traffico tramite risoluzione dns;
      Sono modalità indipendenti e vanno configurate ed attivate. Di base il controllo tramite dns è disattivato quindi se non lo configuri vedrai il servizio arrestato.
      Come ti hanno già indicato ha bisogno del motore del resolver per funzionare.
      Probabilmente il resolver non lo hai configurato correttamente, per questo spesso non ti funziona.
      Ciao Fabio

    Non ho idea però cosa avrei configurato erroneamente visto che non ho fatto altro che reinstallare l'immagine della VM che avevo salvato in Proxmox (in cui il resolver funzionava perfettamente prima). L'unico cambiamento che ho fatto è sull'host fisico su cui gira Proxmox in cui ho aggiunto degli HD e configurato il pool ZFS.
    Una volta fatto ciò ho reinstallato l'immagine salvata di pfsense che nel frattempo giaceva su un altro HD non coinvolto nella modifica.