Wireless card configuration help to access the internet



  • I have the wan and lan working fine. The wireless card (opt1) can connect  laptop->pfsense (a lot faster than my linksys router).

    The issue so far is I can not get the laptop to the Internet. Below is my opt-1 card info. My goal is to let opt-1 (wireless card) access the Internet but not the LAN. Any suggestions or advice on proper configuration is appreciated.

    Wireless card:

    Optional Interface Configuration  ( Enable on)

    General Configuration  ….  DHCP – Mac address, blank –  MTU blank

    IP Configuration–  Bridge with, none –IP Address, blank –  Gateway – blank

    FTP HELPER – Box not checked

    Wireless Configuration – Standard g, Mode Infrastructure (BSS) –802.11GOFDM Protection Mode Off – SSID on-- 802.11G ONLY on --

    Allow Intra-bss Communication – not checked

    Enable WME – not checked

    Enable hide SSID – checked

    Transmit power  99

    Channel, Wep, Authentication, Key rotation, Master Key Regen, Strict Key Regen, (All work correctly, the laptop connected)

    Enable ieeee802.1x – not checked

    DHCP Client Configuration, Hostname –blank

    Lan card:

    IP Configuration:  Bridge with –  none.  IP Address  10.10. xxx.xx

    FTP Helper:  box not checked



  • You have to set the "Mode" to "Access Point" and not to "Infrastructure (BSS)"



  • I think you will need some firewalls rules to allow the appropriate access between OPT1 and WAN.



  • @wallabybob:

    I think you will need some firewalls rules to allow the appropriate access between OPT1 and WAN.

    @GruensFroeschli:

    You have to set the "Mode" to "Access Point" and not to "Infrastructure (BSS)"

    I have tried several configurations. Some from the wiki here.. http://doc.pfsense.org/index.php/Main_Page plus I tried the advice from the two post here (this thread), plus many other suggestions and configuration from the pfsense forums including - firewall rules, bridging, and so on. The result was the same, no internet/traffic to the network from/to the wireless but the laptop could see and connect to the pci wirelless card in the pfsense machine.

    I did read up on subnets and configured them as well. I still did not get a functioning connection to the Internet from/to the wireless. It could be the wireless card, I'm not sure.

    I'm not giving up just heading back to the forums and wiki's and until then I'll use my Linksys box for a semi-functioning, less secure network.

    Thank you all for helping.

    Lou


Log in to reply