Configuring Squid reverse proxy for remote desktop gateway


  • Hi there,

    I've been tinkering with Squid reverse proxy, and have most of my internal sites available using sub paths of my single external domain name.

    Trying to do the same for RD gateway, but can't figure out how I am supposed to configured Squid for this to work?

    The basic setup is fine, as the RDWeb page loads when going to: https://rd.domainname.com/RDWeb
    When doing a remote connection with the gateway configured, it simply says

    Remote resource can't be reached
    

    The event viewer on the gateway server says:

    The user "username", on client computer "10.0.0.1:25783", has initiated an outbound connection. This connection may not be authenticated yet.
    

    I think the issue is related to RPC, and whilst I did try enabling the OWA RPC over HTTPS options in Squid this didn't help.
    Has anyone managed to get this working?

    Cheers
    Eds