Using wireless (ath) as WAN



  • Howdy, Y'all. OK, I am a noob but I really did try to do my research before I asked this question here. I live in an apartment where I can access a public wireless network for free and I want to use this as my internet connection. So, I am going to have my wireless card as WAN and then put my windows box on the wired LAN. I have not been able to set up the ath0 WAN in client mode. I have to use WEP unfortunately. How might I go about configuring this? Thanks in advance for any help you might offer!



  • I already ran such a config with an ath at WAN with WPA. You have to use mode "infrastructure" for this to join the appartment accesspoint. Also if using WEP make sure you use the correct authentication mode "open system" or "shared".



  • Thanks hoba for your quick reply. I have gotten it to work and it works very well. I am seriously impressed with pfsense. I believe that my WEP problem is related to the webgui problem discussed here…http://forum.pfsense.org/index.php/topic,770.msg8676.html#msg8676 . What I ended up doing was switching authentication from the default 'open' to 'shared' at which point I saved the setting and then changed it back to 'open' and resaved the setting. After I renewed the ath0 everything worked fine. I am not sure if this bug is being addressed but the behavior is consistently broken (I tested it three times with fresh installs each time.) It is however, a minor detail in an otherwise amazing product. Thanks to all for your hard work.


Locked