Can't touch a wireless windows 7 computer…



  • im not sure if it's the wireless or what, but i can't communicate with my desktop on windows 7. i can't remote via VNC or RDC, it has an ip, and it gets access to the internet, and my router shows it as having an IP, but i can't connect to it or communicate it from my LAN at all. any ideas?

    also my wireless and LAN are bridged together, and i have a netbook running windows XP that i can reach just fine on the wireless

    im running pfsense 1.2.3-RC1


  • Rebel Alliance Developer Netgate

    Sounds like a Windows 7 firewall issue.

    You might need to make sure your network type is set for "home" or manually adjust the rules.



  • i already did, it will randomly let me connect to it, and other times it wont…



  • turned off the firewall completely, and still nothing…



  • It could be a power save feature. Do something that uses the card like open a web page. Then immediately try and connect to it.
    If that works, check the advanced power saving features and disable anything that shuts off the wireless card under the options.



  • ok i'll try that, but i don't think that's it because it stays signed on MSN messenger and never signs off, so im 99% sure that's not it, but thanks for your replies so far. this is really frustrating as all of my TV shows, music, and movies are on that computer and i can't watch/listen anywhere but on there now :( lol



  • Also make sure some stupid antivirus program doesn't have a built-in firewall that's screwing with things either.



  • i can reach it by using hamachi, but not through the actual LAN IP address, i have AVG installed and i don't know of anything that it has, free version btw, that would be blocking it as all my computers have free AVG. any other ideas?



  • i take that back, that computer doesn't even have an anti-virus on it, because i never download anything directly to it. and hamachi says it can't establish a direct connection so it even uses the free, low bandwidth connection.



  • uninstalled and reinstalled wireless device on the windows 7 machine, still no dice. turned on IPv6 also and nothing.



  • No  issues with rc1 of Windows 7.  Installing the 64 bit release tomorrow at work will be installing and building my new workstation tomorrow.  I will update you this weekend.
    RC



  • Hello,

    I have the same problem but with a linux wireless client. The wireless clients is online, can connect to the internet and so forth but I can't access the wireless client from my LAN using SSH. If I plug the wireless client into my LAN, I have no problems accessing the box through SSH.

    Wireless client to wireless client communicatoin also never works (although I checked the intercommunication thingy in my wireless adapter settings on the pfsense box)

    Best regards,
    Jan



  • @misteragony:

    I have the same problem but with a linux wireless client. The wireless clients is online, can connect to the internet and so forth but I can't access the wireless client from my LAN using SSH. If I plug the wireless client into my LAN, I have no problems accessing the box through SSH.

    Is your wireless LAN bridged to your wired LAN? If not, I believe you will need firewall rules to allow the traffic from LAN to wireless LAN. You could check the firewall log in the web GUI (Status -> System logs, then click on the Firewall tab) to see if the firewall is blocking that traffic. Maybe you need firewall rules to allow the traffic even if the interfaces are bridged.

    @misteragony:

    Wireless client to wireless client communicatoin also never works (although I checked the intercommunication thingy in my wireless adapter settings on the pfsense box)

    You mean the Allow intra-BSS communication thingy under the Interfaces menu? You clicked the Save button after checking the Allow intra-BSS communication item?



  • Is your wireless LAN bridged to your wired LAN? If not, I believe you will need firewall rules to allow the traffic from LAN to wireless LAN. You could check the firewall log in the web GUI (Status -> System logs, then click on the Firewall tab) to see if the firewall is blocking that traffic. Maybe you need firewall rules to allow the traffic even if the interfaces are bridged.

    They are not bridged(LAN=192.168.1.x, WLAN: 192.168.6.x) : I have one rule on my wireless that allows everything from everything (* * * * * *), same on my LAN. Or should I specifically begin stating every protocol(port) that I want to allow?

    Wireless client to wireless client communicatoin also never works (although I checked the intercommunication thingy in my wireless adapter settings on the pfsense box) You mean the Allow intra-BSS communication thingy under the Interfaces menu? You clicked the Save button after checking the Allow intra-BSS communication item?

    Yep, I saved. The box has been rebooted several times since I made that adjustment, and the intra-BSS communication is still checked.

    Best regards,
    Jan



  • @misteragony:

    Or should I specifically begin stating every protocol(port) that I want to allow?

    No.

    Does a ping from the LAN to the wireless client get a response?

    Is sshd (or equivalent) up and running on the wireless client? Does it listen on the standard port?

    What does ssh on the LAN report when it can't connect?


Log in to reply