HELP! My thing just stop working?



  • Hi. I am new to the whole pfsense scene. I am using 1.2.3 RC1 and last night it was working fine since the installation. However this afternoon after ~20hours up time some computers had access to the internet and some didn't. Those computers with no access to internet I was still able to access to the router setup page. I had to reboot for the computers on network to receive access.

    Please help before I finalized my setup if this is ongoing problem I might need to go back to old router.

    thank you.



  • Did those that couldn't access the Internet/pfSense web interface still have IP addresses on the LAN, or did they have autoconfigured IP addresses (ie, do you have a functioning DHCP server)?



  • Also, are the computers who aren't working on a wireless network segment or a wired segment?  Do you have any configured firewall rules or schedules that might impact this?  Did you configure Captive Portal?  Please provide us with more information so we can help you.



  • @cryhavok:
    All the computers can access the router setup page. It was working for 10-18 hours straight then I lost connection on several computers but some still had access to internet.

    @submicron:
    All (5 computers) are connected to switch directly from wire excluding iphone+1 laptop.
    -No rules besides 1 port forward for Bit Torrent.

    • Captive Portal = too advance I didn't touch that area its basically default settings.

    right now I just restarted and added an Access Point (tomato firmware - 192.168.1.0) it was 192.168.1.2 before and wireless connect will hang. I read that I need to assign IP to the router outside the DHCP pool.

    • everything is basically on default excluding 50k NAT table, Static Port for gaming, 1 port forward for p2p, and a few packages to monitor bandwidth. Hopefully this is some help.

    thank you.

    RIGHT NOW: Since I just added the wifi-AP this computer I cannot access the AP setup page (192.168.1.0) but only the computer that I used to configure the AP to 192.168.1.0 picks it up, weird. Prior to that I tried putting access point to 192.168.1.2 but my laptop will time-out on connection such as it'll hang really hard and maybe once every minute get access to internet. however the laptop wifi is blazing fast without being able to access the AP setup page.
    -Sorry if I am repeating myself I am just making sure I am covering everything. So 192.168.1.2 on AP = lag big time 192.168.1.0 on AP = super fast but only 1 computer can access AP (the one that config it initially)



  • Note that, for a /24 (old school class C), such as 192.168.0.x, you must never assign .0 or .255 to any device.

    Ensure too that you've disabled the DHCP client in the Access Point.  I'm fairly confident your problem is because you didn't and some devices had received their DHCP lease from it, with a default gateway of .0 - which won't work.



  • I'm having similar issues and I've even reflashed the CF with no luck.  It seems like everything will be working fine the first day I have 1.2.3 running but the next day it's like the interfaces randomly stop working.  The first time I couldn't get the WLAN to work but my wired PC was working fine.  The second time the wired PC (which I had just started up) would not get DHCP but the WLAN was still working…for a few minutes before I was disconnected and couldn't reconnect.  Rebooting the ALIX did no good.  I didn't have time before leaving for work to test it with static IPs but I'll try it in a few hours.



  • Both of these sound like you're running out of states, check the states RRD graph to check, increase under System -> Advanced if that's the case.



  • I've already switched back to 1.2.2 to avoid any interruptions in internet access.  But I'm pretty sure I remember seeing the state table being up to 10000 which is what it is currently on 1.2.2 and there's no way I had even more than 5000 while I was running 1.2.3.  Of course I never checked to make sure so anything is possible.

    I did do some testing after getting back home and with static IPs I was fine.  The DHCP server was acting like it was disabled.



  • I'm having the same problem…I upgraded to 1.2.3 last week and yesterday my WAN interface keeps losing connection?  So I move WAN interface to another port on my Quad NIC card and it worked for about 10 hours....Woke up and internet back down? Any ideas?



  • What build are you using?  and what type of hardware?
    RC


Log in to reply