[SOLVED] - VMware Tools package configuration



  • Today I updated pfsense 1.2 to 1.2.2 release. Update went flawlessly. After that I added package of VMware-Tools. As it was stated in Package info, they didn't start automatically. There were no /usr/local/etc/rc.d/vmware-guestd.sh and vmware-kmod.sh files - only without .sh extension. When tried to start manually, system responded with missing libgmodule-2.0.so.0

    Could not find any sugestions concerning this module. Can anybody help me to solve this out, as I am not very familiar with FreeBSD things?

    pfsense on ESXi 3.5 Update 4



  • Seeing the same thing. Scott updated that package was updated a few days ago and the update broke it, I let him know.



  • Should be resolved now.



  • Works for me.



  • Thank you guys for your assistance. Now everything runs as expected, which means that the problem stated above is solved. For others - just reinstalled the VMware Tools package and that is it.

    Probably there should be done changes in package info page in this link: http://doc.pfsense.org/index.php/Open_VM_Tools_package regarding Manual start, as after package reinstallation, it started automatically without any problem.

    Thank you again.



  • Yeah the issue that required the manual start has been fixed, I updated that page, thanks.


Log in to reply