• I'm running version:
    1.2.3-RC2
    built on Wed Aug 12 09:48:27 EDT 2009
    FreeBSD 7.2-RELEASE-p3 i386

    It is 2 gig nano on alix board.

    When I check "enable secure shell" and save I get this:

    Fatal error: Call to undefined function: mwxec() in /etc/inc/pfsense-utils.inc on line 1103

    thanks,
    Jim


  • Fixed, thanks for the report!


  • Upgraded tonight to:
    pfSense-1.2.3-2g-20090818-1844-nanobsd.img.gz

    Now the error reads:

    Fatal error: Cannot unset string offsets in /usr/local/www/system_advanced.php on line 184


  • What are you trying to do when you get that? That's a simple unset that's been the same for years.


  • Just, once again, trying to enable the secure shell from the gui.  I also get the same error when trying to uncheck "use device polling."

    Jim


  • I've tried enabling/disabling numerous options on System->Advanced on several different nanobsd versions and none of them generate any errors.


  • I tried it in IE to see if it was browser specific and it is not.  I get this error:

    Fatal error: Cannot unset string offsets in /usr/local/www/system_advanced.php on line 184

    If I try checking secure shell or I try and turn off "use device polling."  My alix router is pretty vanilla.  I did, however, import a m0n0wall config.

    Jim


  • Can you backup your config and email it to me?  cmb at pfsense dot org  It has to be specific to something in your config.


  • This turned out to be a bug in the m0n0wall config conversion code. If someone runs into it in the future, backup the config and replace:

    <diag>with:

    <diag><ipv6nat></ipv6nat></diag>

    save your changes and restore. It'll be fixed in the next few days for future converted configurations.</diag>