Php: /xmlrpc.php: Disallowing CARP sync loop.



  • HI,
    I have upgraded to 1.2.3-RC2 (built on Tue Aug 18 18:28:38 UTC 2009) on 2 soekris (from 1.2)

    I'm trying to enable the sync on them, but I get the following errors:
    on master:

    php: : Beginning XMLRPC sync to https://10.0.10.2:443.
    php: : An error code was received while attempting XMLRPC sync with username admin https://10.0.10.2:443 - Code 2: Invalid return payload: enable debugging to examine incoming payload

    and on the slave system:

    php: /xmlrpc.php: Disallowing CARP sync loop.

    On master system I have:
    Synchronize Enabled
    Synchronize Interface: SYNC
    pfSync sync peer IP: slave IP
    Synchronize rules, NAT …etc
    Synchronize to IP: slave ip
    Remote System Password: slave password

    On slave system I have:
    Synchronize Enabled
    Synchronize Interface: SYNC
    pfSync sync peer IP: master IP
    Synchronize to IP: master ip

    what shall I do? thanks

    (being able to upgrade an embedded image without reflashing is great!!! thanks for the great work!)



  • You have an carp loop.
    Remove the ip addressen by the peer options on the slave machine.


Log in to reply