100% CPU after built on Wed Aug 12 08:40:28 EDT 2009 snapshot



  • For some reason if I use any snapshots after built on Wed Aug 12 08:40:28 EDT 2009 my cpu would always peg at 100%.  No matter what I do it'll always stay at 100%.  So when I revert back to this built on Wed Aug 12 08:40:28 EDT 2009  snapshot CPU goes back to normal with no changes.

    I tried disabling the add-ons with no avail.

    Any ideas?

    Darkk



  • Try doing running: top -S  to find out what is using the processing resources.

    If your internet connection isn't affected in any way then it's probably an issue with ACPI.
    It (ACPI loading an entire core) really doesn't do anything adverse except drawing more power though.  And can be resolved by disabling ACPI on boot or sometimes, via a BIOS update.

    Update:  oh.. I forgot to mention…  If you're running a multi-core system (or have hyperthreading) and see 100% load across all the cores, then it's not likely to be an ACPI issue.  That only seems to fully load 1 core on it's own.



  • It's running on an old Dell Optiplex GX150 PIII 1Ghz processor with 512MB of ram.  I will try the newer snapshot and give that command a try if it pegs 100% again.

    Eventually I will swap out the old hardware with the new Atom or AMD new ultra low power processor when it gets released.  Just waiting on the newer Intel chipset that is more energy efficient with the Atom if AMD don't release their new processor later on this year.

    With newer hardware I'll be able to bump up to more RAM and processing power.

    Darkk



  • @Darkk:

    It's running on an old Dell Optiplex GX150 PIII 1Ghz processor with 512MB of ram.  I will try the newer snapshot and give that command a try if it pegs 100% again.

    Eventually I will swap out the old hardware with the new Atom or AMD new ultra low power processor when it gets released.  Just waiting on the newer Intel chipset that is more energy efficient with the Atom if AMD don't release their new processor later on this year.

    With newer hardware I'll be able to bump up to more RAM and processing power.

    Darkk

    For the Atom based solutions, there already are available solutions.  These are based on the mobile versions of the 945GC chipset (945GSE).  Unfortunately, all of them are based on the Single core Atom.

    From Intel, there is the D945GSEJT.  It accepts DC power connections so you don't need a PSU but it uses a Realtek NIC.
    From MSI, there is the IM-945GSE-A.  It comes with a pair of Intel 82574L PCI-e GBe controllers onboard.
    Jetway has the NF94, which, like the Intel, used the same Realtek NIC.



  • Ok, I've loaded it with the latest snapshot and seems IDLEPOLL will take up whatever CPU process is available.  It currently hovers around 85-90% as a process.

    Going to revert back to my previous snapshot and see if I get the same results with that process.

    Darkk



  • Do you absolutely have to use Polling on your NICs?



  • Yep, that what is was.  I am not sure if it was enabled by default since I don't mess around with those settings too much.  Also not sure why it was different from the previous snapshot.  Something new with idlepoll?

    Thanks for the help.

    Darkk



  • @Darkk:

    Yep, that what is was.  I am not sure if it was enabled by default since I don't mess around with those settings too much.  Also not sure why it was different from the previous snapshot.  Something new with idlepoll?

    Thanks for the help.

    Darkk

    Nothing new.  It's just a means of reducing CPU usage if the NIC proves to be overloading the system with interrupts.  Try disabling Polling from System -> Advanced -> Miscelaneous -> Device Polling.  Uncheck the Checkbox to disable device polling.



  • I did that.  Before I disabled them it was working fine.  No hardware changes and then it started doing that so I disabled the device polling which fixed the 100% cpu problem.



  • Hi,
    i just updated to last snapshot (1.2.3-RC3 built on Mon Sep 14 01:31:26 UTC 2009) and now IDLEPOLL take make CPU to 100%. Before I've always used polling on nics and no problems. I've not changed anything on my hw.
    Any idea to resolve? instead of disabling polling?

    Thanks for help!



  • @Emab:

    Hi,
    i just updated to last snapshot (1.2.3-RC3 built on Mon Sep 14 01:31:26 UTC 2009) and now IDLEPOLL take make CPU to 100%. Before I've always used polling on nics and no problems. I've not changed anything on my hw.
    Any idea to resolve? instead of disabling polling?

    Thanks for help!

    Is it possible that polling, while checked, never actually worked and started working in more recent builds?



  • I don't think so…
    Anyone could confim this?


  • Rebel Alliance Developer Netgate

    As far as I've been able to tell, IDLEPOLL is just that, idle polling.

    It always shows 100% CPU because it's technically doing polling during the idle time. Any time I've used polling I have seen this behavior.

    Unfortunately it makes the CPU usage meter a tad useless, but I'm not sure there is a way around it.



  • I've never seen CPU at 100%
    So I've never used polling?


  • Rebel Alliance Developer Netgate

    @Emab:

    I've never seen CPU at 100%
    So I've never used polling?

    Did you turn it on?

    Polling is off by default and is not needed in most places. You really only need polling if your system is passing more packets than it can handle interrupts for, which unless you have really, really old hardware, is unlikely in most places with moderate bandwidth/throughput. And even then, if it's that old, it probably doesn't support polling properly.

    In places I've tested polling it's performed the same or slightly worse than without polling, but that will vary from one hardware setup to another, and depends largely on your workload.



  • I've always (from years ago) enabled polling, but now I think that never worked, becouse I've never seen CPU to 100%. I think that I don't need it, so I disabled it.



  • so does this mean its OK to have 100% cpu usage with polling?



  • I think so…



  • it seems to be working fine….just seems odd.


Log in to reply