Pfsense IPSEC site a site + zywall



  • bonjour

    j'essai en vains de faire fonctionner un VPN entre 2 sites distants

    voici la configuration

    site distant 1 : 192.168.1.0/24 (zyxell zywall) passerelle 192.168.1.1
    site distant 2 : 172.16.2.0/24 (pfsense) passerelle 172.16.2.254

    la connexion du tunnel vpn s'effectue sans problème, ici pas de problème

    en revanche quand je ping un poste (ou même la passerelle) d'un coté ou de l'autre je n'ai aucune réponse.
    j'ai donc regardé mes règles IPSEC et fait en sorte que tout puisse arrivé

    Proto  Source  Port  Destination  Port  Gateway

    • *         * *                 * *

    malheureusement cela ne fonctionne toujours pas, je me demande si il ne me manque pas une route static quelque part ?
    le problème étant que je ne souhaites pas jouer avec la table de routage d'un réseau en production…

    merci



  • Bonjour,

    Vérifie des deux coté les paramètres de la phase 2.

    La regle
    Proto    Source    Port    Destination    Port    Gateway
    *            *            *    *                    *    *       
    est faite dans l'onglet ipsec?



  • j'ai revu mes réglages ipsec (au niveau du masque de sous reseau) et je peux pinger de pfsense vers zywall
    l'inverse n'est pas encore possible mais dans les logs j'ai vu un blocage ICMP de l'interface ENC0(ipsec ?) vers LAN (pfsense)

    pourtant, j'ai bien tout autorisé dans l'onglet ipsec
    Proto     Source     Port     Destination     Port     Gateway

    • *            *    *                    *    *

    donc 2 choses, soit il me manque une route quelque part soit j'ai une règle qui bloque du coté de pfsense (le ping part bien du zywall et est bloqué par pfsense, donc je pencherais plutot de ce coté là)

    edit : finalement j'ai trouvé d'ou venais l'erreur (regle trop agressive a un endroit)

    le ping fonctionne dans les 2 sens et sans toucher les tables de routage

    reste à optimiser le flux, j'ai des pertes de paquet (75%) quand je ping du site distant vers pfsense
    en revanche depuis pfsense aucune perte (100%)

    il est possible que cela vienne de la ligne adsl (abonnement 512k adsl …)


Log in to reply