4gb nanobsd embedded image + Soekris 5501 or Soekris 4401



  • We seems to not be able to get the Soekris 5501 or Soekris 4401 box working. Connected via Serial we get to the point were it says "Missing Operating System"

    Anyone else having this issue ?

    net5501 bios 1.33
    net4401 bios 1.28

    comBIOS ver. 1.28  20050529  Copyright (C) 2000-2005 Soekris Engineering.

    net4801

    0256 Mbyte Memory                        CPU Geode 266 Mhz

    Pri Mas  SanDisk SDCFH2-4096            LBA Xlt 995-128-63  4013 Mbyte

    Slot  Vend Dev  ClassRev Cmd  Stat CL LT HT  Base1    Base2  Int
    –-----------------------------------------------------------------
    0:00:0 1078 0001 06000000 0107 0280 00 00 00 00000000 00000000
    0:06:0 100B 0020 02000000 0107 0290 00 3F 00 0000E101 A0000000 10
    0:07:0 100B 0020 02000000 0107 0290 00 3F 00 0000E201 A0001000 10
    0:08:0 100B 0020 02000000 0107 0290 00 3F 00 0000E301 A0002000 10
    0:18:2 100B 0502 01018001 0005 0280 00 00 00 00000000 00000000
    0:19:0 0E11 A0F8 0C031008 0117 0280 08 38 00 A0003000 00000000 11

    1 Seconds to automatic boot.  Press Ctrl-P for entering Monitor.
    Missing operating system



  • You have a bootable partition on the CF?



  • I would not know all I did is follow the pfsense wiki instruction for a embedded image install from pfsense.org ; I would image that is the installation method. I am using  Mac OS X instructions and I notice that when I view partitions from Mac OS X I see 3 of them, but don't know if they are bootable, How would I check for a bootable partition ?

    ???



  • Missing operating system is a message I've seen from a couple of different systems that didn't have a bootable partition.

    I don't know how you would display the partition types in MAC OS. Perhaps there is a man page or help for the utility that displays the partitions.

    In pfSense/FreeBSD I would check the disk with fdisk as follows:

    fdisk ad0

    ******* Working on device /dev/ad0 *******
    parameters extracted from in-core disklabel are:
    cylinders=1942 heads=16 sectors/track=63 (1008 blks/cyl)

    Figures below won't work with BIOS for partitions not in cyl 1
    parameters to be used for BIOS calculations are:
    cylinders=1942 heads=16 sectors/track=63 (1008 blks/cyl)

    Media sector size is 512
    Warning: BIOS sector numbering starts with sector 1
    Information from DOS bootblock is:
    The data for partition 1 is:
    sysid 165 (0xa5),(FreeBSD/NetBSD/386BSD)
        start 63, size 1957473 (955 Meg), flag 80 (active)
    beg: cyl 0/ head 1/ sector 1;
    end: cyl 917/ head 15/ sector 63
    The data for partition 2 is:
    <unused>The data for partition 3 is:
    <unused>The data for partition 4 is:
    <unused>Notice that partition 1 has the active flag set - that means its bootable.

    (The above display is from a disk holding the full version of pfSense, not the embedded version.)</unused></unused></unused>



  • Sounds like it wasn't written to CF properly. I have a 4801 sitting next to me running nanobsd on 4 GB.  Make sure you're following the instructions here:
    http://doc.pfsense.org/index.php/HOWTO_Install_pfSense#Embedded_.28Compact_Flash.29_Installation



  • Does are the instructions I followed…. did the installation from the MAC OS X part. Tried it twice.

    Could it be that the MAC OS X instructions on that page are incorrect ?

    Regards,



  • They're correct. If you unzip the file and then write it through gunzip, that will cause problems.

    On my Mac I typically write images with physdiskwrite in a Parallels VM to avoid the potential of a fat fingered command overwriting the wrong disk.



  • tailing /var/log/system.log when you plug in the CF card reader should reliably reveal the pathname of the CF device.  Copy and paste to avoid mistakes.



  • I have managed to Image the CF 4 GB image [August 26] successfully on both Soekris 4401 & 5501 boxes. Unfortunately what worked for me was to use Parallels and a FreeBSD OS I have as a VM [7.2 Stable].

    Tried again with instruction set from the WIKI in OS X , and images are not booting up. I will look to do another test once a newer 4GB image is released.

    Anyone else having trouble in Mac OS X without using a VM solutions ?

    Regards,


Log in to reply