Nanobsd snapshot 9/5 hangs at boot



  • Console output follows.  Note that 3 slices are now labeled as bootable.  And it hung at the webConfigurator startup

    I reflashed with this image:

    http://snapshots.pfsense.org/FreeBSD_RELENG_7_2/pfSense_RELENG_1_2/nanobsd/pfSense-1.2.3-2G-20090905-1102-nanobsd.img.gz

    …thinking that if the slices actually shrunk, a fresh flash would be in order.

    The CF card I tried for this is fine, in spite of what the error message suggests.

    
    PC Engines ALIX.2 v0.99h
    640 KB Base Memory      
    261120 KB Extended Memory
    
    01F0 Master 848A SanDisk SDCFH2-002G                     
    Phys C/H/S 3970/16/63 Log C/H/S 992/64/63                
    
    1   FreeBSD
    2   FreeBSD
    3   FreeBSD
    
    Boot:   1 
    //bboooott..ccoonnffiigg::  --DD
    
    Consoles: internal video/keyboard  serial port  
    BIOS drive C: is disk0                          
    BIOS 640kB/261120kB available memory            
    
    FreeBSD/i386 bootstrap loader, Revision 1.1
    (sullrich@RELENG_1_2__FreeBSD_7_2_snapshots.pfsense.org, Sat Sep  5 10:24:28 UT)
    Loading /boot/defaults/loader.conf                                              
    /boot/kernel/kernel text=0x737db8 data=0x13cdac+0x51c60 |                       
    -                                                                               
    Hit [Enter] to boot immediately, or any other key for command prompt.           
    Booting [/boot/kernel/kernel]...                                                
    Copyright (c) 1992-2009 The FreeBSD Project.                                    
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994        
            The Regents of the University of California. All rights reserved.       
    FreeBSD is a registered trademark of The FreeBSD Foundation.                    
    FreeBSD 7.2-RELEASE-p3 #0: Sat Sep  5 10:43:14 UTC 2009                         
        sullrich@RELENG_1_2__FreeBSD_7_2_snapshots.pfsense.org:/usr/obj.pfSense/usr7
    Timecounter "i8254" frequency 1193182 Hz quality 0                              
    CPU: Geode(TM) Integrated Processor by AMD PCS (498.05-MHz 586-class CPU)       
      Origin = "AuthenticAMD"  Id = 0x5a2  Stepping = 2                             
      Features=0x88a93d<fpu,de,pse,tsc,msr,cx8,sep,pge,cmov,clflush,mmx>AMD Features=0xc0400000<mmx+,3dnow!+,3dnow!>real memory  = 268435456 (256 MB)                                               
    avail memory = 248639488 (237 MB)                                               
    pnpbios: Bad PnP BIOS data checksum                                             
    wlan: mac acl policy registered                                                 
    K6-family MTRR support enabled (2 registers)                                    
    cryptosoft0: <software crypto="">on motherboard                                   
    pcib0: <host to="" pci="" bridge="">pcibus 0 on motherboard                             
    pci0: <pci bus="">on pcib0                                                        
    Geode LX: PC Engines ALIX.2 v0.99h tinyBIOS V1.4a (C)1997-2007                  
    pci0: <encrypt decrypt,="" entertainment="" crypto="">at device 1.2 (no driver attached)
    vr0: <via 10="" vt6105m="" rhine="" iii="" 100basetx="">port 0x1000-0x10ff mem 0xe0000000-0xe0
    vr0: Quirks: 0x2                                                                
    vr0: Revision: 0x96                                                             
    miibus0: <mii bus="">on vr0                                                       
    ukphy0: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus0                  
    ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto                   
    vr0: Ethernet address: 00:0d:b9:17:9b:a8                                        
    vr0: [ITHREAD]                                                                  
    vr1: <via 10="" vt6105m="" rhine="" iii="" 100basetx="">port 0x1400-0x14ff mem 0xe0040000-0xe0
    vr1: Quirks: 0x2                                                                
    vr1: Revision: 0x96                                                             
    miibus1: <mii bus="">on vr1                                                       
    ukphy1: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus1                  
    ukphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto                   
    vr1: Ethernet address: 00:0d:b9:17:9b:a9                                        
    vr1: [ITHREAD]                                                                  
    vr2: <via 10="" vt6105m="" rhine="" iii="" 100basetx="">port 0x1800-0x18ff mem 0xe0080000-0xe0
    vr2: Quirks: 0x2                                                                
    vr2: Revision: 0x96                                                             
    miibus2: <mii bus="">on vr2                                                       
    ukphy2: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus2                  
    ukphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto                   
    vr2: Ethernet address: 00:0d:b9:17:9b:aa                                        
    vr2: [ITHREAD]                                                                  
    isab0: <pci-isa bridge="">port 0x6000-0x6007,0x6100-0x61ff,0x6200-0x623f,0x9d00-00
    isa0: <isa bus="">on isab0                                                        
    atapci0: <amd cs5536="" udma100="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x30
    ata0: <ata 0="" channel="">on atapci0                                                
    ata0: [ITHREAD]                                                                 
    ata1: <ata 1="" channel="">on atapci0                                                
    ata1: [ITHREAD]                                                                 
    ohci0: <ohci (generic)="" usb="" controller="">mem 0xefffe000-0xefffefff irq 12 at devi0
    ohci0: [GIANT-LOCKED]                                                           
    ohci0: [ITHREAD]                                                                
    usb0: OHCI version 1.0, legacy support                                          
    usb0: <ohci (generic)="" usb="" controller="">on ohci0                                  
    usb0: USB revision 1.0                                                          
    uhub0: <amd 1="" 9="" ohci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb0            
    uhub0: 4 ports with 4 removable, self powered                                   
    ehci0: <amd cs5536="" (geode)="" usb="" 2.0="" controller="">mem 0xefffd000-0xefffdfff irq 120
    ehci0: [GIANT-LOCKED]                                                           
    ehci0: [ITHREAD]                                                                
    usb1: EHCI version 1.0                                                          
    usb1: companion controller, 4 ports each: usb0                                  
    usb1: <amd cs5536="" (geode)="" usb="" 2.0="" controller="">on ehci0                          
    usb1: USB revision 2.0                                                          
    uhub1: <amd 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usb1            
    uhub1: 4 ports with 4 removable, self powered                                   
    cpu0 on motherboard                                                             
    orm0: <isa option="" rom="">at iomem 0xe0000-0xea7ff pnpid ORM0000 on isa0           
    ppc0: parallel port not found.                                                  
    sio0 at port 0x3f8-0x3ff irq 4 flags 0x30 on isa0                               
    sio0: type 16550A, console                                                      
    sio0: [FILTER]                                                                  
    sio1 at port 0x2f8-0x2ff irq 3 on isa0                                          
    sio1: type 16550A                                                               
    sio1: [FILTER]                                                                  
    RTC BIOS diagnostic error 80<clock_battery>Timecounter "TSC" frequency 498053225 Hz quality 800                            
    Timecounters tick every 10.000 msec                                             
    IPsec: Initialized Security Association Processing.                             
    ad0: 1953MB <sandisk sdcfh2-002g="" hdx="" 4.32="">at ata0-master PIO4                  
    WARNING: Expected rawoffset 0, found 63                                         
    WARNING: Expected rawoffset 0, found 1939455                                    
    Trying to mount root from ufs:/dev/ufs/pfsense0                                 
    Setting up embedded specific environment... done.                               
    
         ___
     ___/ f \
    / p \___/ Sense
    \___/   \
        \___/
    
    Welcome to pfSense 1.2.3-RC2...
    
    Mounting filesystems... done.
    Creating symlinks......done.
    Launching the init system... done.
    Initializing.................. done.
    Starting device manager (devd)...done.
    Loading configuration......done.
    Updating configuration...done.
    Cleaning backup cache...done.
    glxsb0: <amd geode="" lx="" security="" block="" (aes-128-cbc,="" rng)="">mem 0xefff4000-0xefff70
    Setting up extended sysctls...done.
    Syncing user passwords...done.
    Starting Secure Shell Services...done.
    Setting timezone...done.
    Starting syslog...done.
    Configuring LAN interface...done.
    Configuring WAN interface...done.
    Configuring OPT interfaces...   OPT1 (OPT1)... done.
    Configuring CARP interfaces...done.
    Starting OpenNTP time client...done.
    Configuring firewall......done.
    Starting webConfigurator...ad0: TIMEOUT - WRITE_MUL retrying (1 retry left) LBA7</amd></sandisk></clock_battery></isa></amd></amd></amd></amd></ohci></ohci></ata></ata></amd></isa></pci-isa></generic></mii></via></generic></mii></via></generic></mii></via></encrypt></pci></host></software></mmx+,3dnow!+,3dnow!></fpu,de,pse,tsc,msr,cx8,sep,pge,cmov,clflush,mmx> 
    

  • Rebel Alliance Developer Netgate

    I just tried the 2GB image from this morning and it booted up just fine on my ALIX.

    I'm also seeing all three slices labeled as bootable, but obviously the third slice (config) shouldn't be… not sure how that's happening.

    I did put in some changes that were used in making the different sized nano images faster, that could be to blame, but it doesn't appear to hurt anything for me.

    It boots up all the way and is fully usable (so far)



  • Ok, tried it again with a different CF card and it worked.  The card that failed is good as far as I know.  I'll have to spend a little time with it to be sure.

    Thanks!


Log in to reply