Squid does not pass the firewall rules.



  • Hello, I have a problem, I am not able to deal with, I count on your help …
    Well, I have in my firewall 4 NICs

    LAN 192.168.0.254 (NETWORK SERVERS)
    200.x.x.x WAN (Link DEDICATED)
    Àpt0 192.168.8.254 (LOCAL NETWORK)
    Apt1 10.1.1.3 (ADSL)

    Well, configured so that the LAN interface only accesses the internet via the WAN, and the interface àpt0 only accesses the internet by Apt1.
    Well so far so good ... I installed Squid to control content, only after I installed the squid, all interfaces only access the internet over the WAN, bypassing the firewall settings made previously.
    I would like if possible that the squid, complied with the settings made in the firewall for each network access the Internet so that was configured.
    However if you do not like, would change some information in the squid that used the interface Apt1 to go to the Internet?

    Thanks



  • help me please



  • Hi good afternoon.

    Go to General settings and check "Allow users on interface" and "Transparent proxy" Proxy port: 3128. Save and you are off to go.

    jigp
    1.2.x


Log in to reply