Problem with Squd transparent mode



  • Hi all,
    Can you can provide a help with Squid in PfSense 1.2.2.

    One year ago I have installed PfSense 1.2.0. everything was working till 2 months. After a have installed HAPV antivirus the proxy not working in transparent mode.  
    The HAPV was not working (or I was not be able to do it), but I have uninstalled it.

    The problem is that users are not forced to use proxy (transparent mode is checked).
    If an browser is manually configured to use proxy on port 3128 everything works.

    I do re-installation of the packages 3 times and now update to PfSense 1.2.3., but the problem is still here.
    The configuration is
    WAN
    LAN   ->Vlan 192.168.0.0
    OPT1->Vlan 192.168.1.0
    OPT2->Vlan 192.168.2.0

    Can somebody help me?



  • Hi good afternoon.
    Done that. I end up removing HAVP and Install Avira on workstations.

    jigp
    1.2.2



  • How I got mine to work after trial and error was to as follows.

    Squid…uncheck transparent mode. Uncheck disable X-forward and Via.

    Havp..check transparent
            proxy port 3121
            parent proxy Lan ip:squid port...example 192.168.0.1:3128
            enabled forward IP
            enable block file if error scanning

    This config seems to works great for me.



  • @ColdFusion

    If I uncheck transparent mode, users now can use their own proxy:port..



  • Do you have HAVP installed as well?



  • ColdFusion: Nope i dont have HAVP.. Just squid+SG+traffic shaper

    jigp



  • I was referencing with HAVP in transparent mode…and squid transparent to be unchecked for Squid,Squidguard and Havp to work right.




Log in to reply