Pfsense rewriting my LAN IPs



  • I've got an Alix 3 port box doing routing and NAT.

    WAN-LAN is routing with a routable subnet on the LAN
    WAN-OPT1 is doing NAT with a 192.168.x.x subnet.

    My problem is that outgoing connections from machines on the LAN side are getting their IPs rewritten with the WAN side address of pfsense.

    So a mail server connection appears as if it's originating from pfsense's wan IP and muddles things up when it identifies itself as another.

    How do I turn the rewrite off for LAN -> outside world traffic?



  • Firewall –> NAT --> outbound
    Enable manual outbound NAT rules.
    Delete the autocreated rule and nothing should be rewritten anymore.
    Make sure you have the correct static routes on the upstream devices set.


Log in to reply