Problem with wep on rc2



  • I upgraded from rc1 to rc2 and as a result the wifi was not working anymore. When I did a scan available networks on the client machine, it was reporting my ssid was not wep enabled. I then tried rc2a->f still no wifi with wep.
    I checked the same issue as previous topic : http://forum.pfsense.org/index.php/topic,1709.msg9890.html#msg9890

    I then downgraded to rc1 and my wifi network was back up with reported wep. I am using adhoc (ibss). 128bit wep on a netgear 311 802.11b.
    What has changed in rc2?



  • Reboot the unit twice after upgrading and see if this helps.  WEP somehow took 1 reboot more when we tested it with RC2 during the hackathon but it does work ok.



  • I have the same problem here running rc2 and an Atheros AR5213A chipset card WEP just doesn't work at all regardless of the number of reboots I do. Sadly the pcmcia card in my laptop only supports WEP and not WPA…

    :(

    SC



  • Make sure your setting for "shared" or "open system" is correct. This is important for WEP. You should prefer "open system" as it is more secure (if you can call WEP secure at all).



  • @hoba:

    Make sure your setting for "shared" or "open system" is correct. This is important for WEP.

    I've tried 'shared', 'open' and 'both'. None seem to make any difference. I finally got fed up and double checked with kismet which reports that there's no WEP enabled - even though the web interface says it is.

    @hoba:

    You should prefer "open system" as it is more secure (if you can call WEP secure at all).

    I appreciate that WEP isn't secure, but it's simply the first step in keeping my wireless data secure. ATM I've got the captive portal running (https), I guess the next step is going to be some mechanism that would allow me to force wireless connections to have to connect to a vpn in order to send any traffic … then WEP wouldn't matter at all.. (any hints on the best mechanism to do this would be appreciated :D )

    thanks

    SC



  • guess the next step is going to be some mechanism that would allow me to force wireless connections to have to connect to a vpn in order to send any traffic … then WEP wouldn't matter at all.. (any hints on the best mechanism to do this would be appreciated Cheesy )

    setup ptpp server on pfsense
    block all trafic on wireless interface
    open all trafic on ptpp clients interface

    now you can only internet true vpn


Locked