Automaticamente a portal cautivo http://192.168.1.1:8000



  • :-
    Buenas a todos gracias por toda la ayuda que estoy consiguiendo aqui, bueno el problema que tengo es que cuando reiniciio mi server por alguna falla como corte de luz, los clientes
    que ya habian navegado anteriormente se quedan sin navegar ya que tienen que volver a escribir en el browser http://192.168.1.1:8000 osea no sale automatico, se supone que anteriormente ya se logearon, pense que no tenian que volver hacer eso, y bueno el problema es que no sale automatico tienen que hacer siempre eso los clientes..cuando cargan
    algo o ponen una pagina www.google.com no carga y bueno tengo que llamarle y decirle que entren a la pagina de arriba y escriban todo eso..entienden?? bueno y eso un fastidio..
    lo mejor seria que salga automaticamente para poner username o password…o aun mejor que ya no pida...mi pregunta es ??? si se va la luz los clientes tienen que identificarse otra vez con el servidor??????????....o en todo caso como se hace para que sea automaticamente si es que hay algun cambio en el server para que siempre aparesca eso por primera vez siempre y cuando no haya internet??



  • :) hola..

    ya se ha hablado en varias ocasiones de este tema, cuando modificaste el archivo .html de entrada del captive portal borraste parte del codigo necesario para que se active de manera autoamtica la pagina de entrada, o tienes algun error en dicho html. verificalo o colocalo aca para que lo revisemos entre todos.



  • HOla a todos miren este es mi codigo: la verdad lo copie de un lugar

    <title>Bienvenido a Internet - Casa</title>

    INTERNET HOME 2009

    Ingrese en las casillas en blanco su username y password que se le proporciono a su email, luego haga click en boton LOGIN para iniciar el Internet.Si aun no tiene esos datos llame al 777777 para que aperturen su cuenta.

    si aun tienes problemas para accesar al servicio es posible debido a que tu cuenta fue bloqueada
    debido a algun retraso de pago.

    Los depositos se realizan en el BANCO DE SCOTIABANK

    Identificate

    <form method="post" action="$PORTAL_ACTION$">

    <fieldset>

    <legend>Datos de Cuenta</legend>

    <label for="Username">Username:</label>
    ()

    <label for="Password">Password:</label>
    ()

    </fieldset>

    </form>

    tambie npor ahi escuche que hay que configurar DHCP Server??



  • :) hola…

    tal como te comente el codigo tiene detalles.

    
    (*)  
    (*)  
    (ok) 
    (*)  
    (ok) <title>Bienvenido a Internet - Casa</title>
    (ok)  
    (ok)  
    (ok)  
    
    # INTERNET HOME 2009
    
    (ok)  
    
    Ingrese en las casillas en blanco su username y password que se le proporciono a su email, luego haga click en boton LOGIN para iniciar el Internet.Si aun no tiene esos datos llame al 777777 para que aperturen su cuenta.
    
    (ok)  
    
    si aun tienes problemas para accesar al servicio es posible debido a que tu cuenta fue bloqueada
    debido a algun retraso de pago.
    
    (ok)  
    
    Los depositos se realizan en el BANCO DE SCOTIABANK
    
    (ok)  
    
    ## Identificate
    
    (x1)  
    
    <form method="post" action="$PORTAL_ACTION$">
    
    (ok)   
    
    <fieldset>
    
    (ok)   <legend>Datos de Cuenta</legend>
    
    (ok)   
    
    (ok)      <label for="Username">Username:</label>
    (x2)      ()
    (ok)   
    
    (ok)   
    
    (ok)      <label for="Password">Password:</label>
    (x3)       ()
    (ok)   
    
    (x4)   
    
    (ok)   </fieldset>
    
    (ok)   
    
    (ok) </form>
    
    (ok) 
    

    donde:
    (*) es codigo que considero que no es necesario
    (ok) codigo que considero que esta bien
    (x..) codigo que considero que esta mal.

    para x1:
     tienes:

    <form method="post" action="$PORTAL_ACTION$"> 
     deberia ser:

    para x2:
     tienes:        ()
     deberia ser:

    para x3:       
      tienes:       
      deberia ser:

    para x4:
      tienes:       
      deberia ser:

    lo mas grave es x1 y x4 a mi juicio… esperemos comentarios de otros foristas
    </form>



  • hola amigo mira y este es el codigo html cuando el id y el password no son correctos mira

    <title>Datos erroneos - Verifique</title>

    INTERNET HOME 2009

    Tienes que ingresar correctamente tu cuenta de internet, tu username y password
    para que puedas hacer uso del servicio de Internet.

    Si al ingresar tu cuenta tienes problemas,envia un email al correo que te proporciono tu
    username y password, de inmediato se contactaran para la brindarte una nueva cuenta.

    INICIO

    <form method="post" action="$PORTAL_ACTION$">

    <fieldset>

    <legend>Datos de Cuenta</legend>

    <label for="Username">Username:</label>
    ()

    <label for="Password">Password:</label>
    ()

    </fieldset>

    </form>



  • toma un tiempo y lee un poquito…

    aca puedes empezar.

    http://www.programacion.com/html/tutorial/curso/



  • Hola…amigo probe tu codigo y no funciona igual tengo que poner el bendito  http://192.168.1.1:8000  y despues los clientes tienen que poner
    su username y password...mis ips todas son fijas..en services ----porta cautivo----Disable concurrent logins estaesta con check probe sin check y con check esta opcion mas Disable MAC filtering y se comporta igual tengo que agregar siempre a http://192.168.1.1:8000  y no es automatico ya que si hago click en www.google.com no carga nada!!!, no se porqui
    pasa eso..alguien podria ayudarme porfavor???...no manejo nada de DHCP, todos mis clientes ya estan con 192.168.1.x y cambiarlos seruia un problema..graciuas...de antemano
    a todos..



  • http://forum.pfsense.org/index.php/topic,19351.0.html

    ya revisaste lo expuesto en ese post??

    o cambia

    <form method="post" action="http://192.168.1.1:8000/">

    por:</form>



  • @sanchezluys:

    http://forum.pfsense.org/index.php/topic,19351.0.html

    ya revisaste lo expuesto en ese post??

    o cambia

    <form method="post" action="http://192.168.1.1:8000/">

    por:
    </form>

    No te encierres en un problema de HTML.

    Esto me suele suceder cuando alguna cuenta caduca, entonces www.google.com necesita apuntar a 192.168.1.1:8000, y hay que refrescar el caché. Apretando Ctrl+F5 cuando no carga arregla el problema.



  • Cuando una cuenta caduca?????????? yo no pongo nada de fecha de caducidad, no uso eso. El problema se presenta cuando apago el pfsense para hacerle un mantenimiento fisico a la pc o cuando se va la luz
    y cuando reinicia entonces las pcs clientes siempre tienen que poner http://192.168.1.1:8000  para que puedan otra vez ingresar a sus cuentas y hacer uso del internet. pero se supone que eso debe ser automatico, solo estoy usando el pfsense para bloquear algunos puertos standares de p2p y optimizar el voip. Pero eso de apretar Ctrl+F5??? no he probado ni se me ocurrio, no creo que pase nada
    pero bueno de todas formas lo probare y vere que pasa, tambien probare eso del DNS del puerto 53, algo asi..



  • Ctrl+F5 refresca la página sin tener en cuenta el caché (como F5 normalmente haría).

    Tu problema es que necesitás que www.google primero apunte a 192.168.1.1, y si el usuario logra autenticarse, que apunte a 64.233.163.99. Una vez que el usuario se desloguee del portal cautivo (en caso de un reinicio en tu caso, o de que una cuenta caduque en el mio) necesitas que el navegador sepa que tiene que volver a apuntar a 192.168.1.1.



  • Hola a todos ya puse todo esto  y nada no funciona!!,agregue tambien el DNS y nada…tengo que poner siempre el bendido http://192.168.1.1:8000... y ahi recien sale el portal cautivo, probe con html que viene por defecto en el portal cautivo pensando que esta mal mi HTML pero igual nada..
    no entiendo eso de como hacer que mi server apunte??..porfavor amigo explicamelo como se hace
    es algun codigo HTML???..gracias de antemano.

    no funciona ni asi  por:

    <form method="post" action="http://192.168.1.1:8000/index.php">
    ni tampoco asi        por:

    ni tampoco lo del DNS (53)...no se que estaria pasando??..alguna idea amigos??


    </form>



  • ¡Hola!

    La regla que añades en LAN no sirve para nada ya que la primera incluye todo.

    Saludos,

    Josep Pujadas



  • Hola…osea tengo que borrar el que dice source  LAN Net???y solo dejo el TCP/UDP???



  • ¡Hola de nuevo!

    No, al revés. Tienes que dejar la "default" a menos que quieras restringir cosas. Y con la de resolución DNS no tienes suficiente.

    http://www.bellera.cat/josep/pfsense/regles_cs.html

    Otra cuestión es qué está pasando con el portal cautivo … que no se dispara ...

    http://www.bellera.cat/josep/pfsense/portal_cs.html

    Saludos,

    Josep Pujadas



  • Bueno ya lo regrese como estaba antes,pero hasta ahora no logro que funcione el portal cautivo con total normalidad…no pasa nada
    las pcs tienen que poner aun para entrar a la red cuando se resetea mi server pfsense deben de poner-..siempre al iniciio....http://192.168.1.1:8000
    porfavor a ver si alguien me puede ayudar hasta ahora hace 1 mes que no me funciona el pfsense...se lo agradeceria muchisismooooooooooo



  • una pregunta ese portal cautivo soporta animaciones en flas slw


Log in to reply