OpenVPN Client auf Win7 x64 zu IPCOP OpenVPN Roadwarrior



  • Hallo Leute,

    Ich habe ein Problem mit meinem OpenVpnClient auf meinem Windows 7 x64 System.
    Ich verwende hier den neuesten Client
    Wenn ich nun eine Verbindung zu meinem IPCOP in der Firma aufbauen möchte erhalte ich die Meldung:

    Mon Oct 19 15:51:51 2009 OpenVPN 2.1_rc7 Win32-MinGW [SSL] [LZO2] [PKCS11] built on Jan 29 2008
    Mon Oct 19 15:51:51 2009 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
    Mon Oct 19 15:51:54 2009 LZO compression initialized
    Mon Oct 19 15:51:54 2009 WARNING: normally if you use –mssfix and/or --fragment, you should also set --tun-mtu 1500 (currently it is 1400)
    Mon Oct 19 15:51:54 2009 Control Channel MTU parms [ L:1442 D:138 EF:38 EB:0 ET:0 EL:0 ]
    Mon Oct 19 15:51:54 2009 Data Channel MTU parms [ L:1442 D:1442 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
    Mon Oct 19 15:51:54 2009 Local Options hash (VER=V4): 'a6ae7d69'
    Mon Oct 19 15:51:54 2009 Expected Remote Options hash (VER=V4): '006a55ce'
    Mon Oct 19 15:51:54 2009 Socket Buffers: R=[8192->8192] S=[8192->8192]
    Mon Oct 19 15:51:54 2009 UDPv4 link local (bound): [undef]:1194
    Mon Oct 19 15:51:54 2009 UDPv4 link remote: xx.xx.xx.xx:1194
    Mon Oct 19 15:51:54 2009 TLS: Initial packet from xx.xx.xx.xx:1194, sid=e8adfe52 018eb1e0
    Mon Oct 19 15:51:54 2009 VERIFY OK: depth=1, /C=AT/ST=xxxxx/L=xxxxx/O=xxxxx/OU=IT/CN=xxxxx/emailAddress=xxx@xxx.com
    Mon Oct 19 15:51:54 2009 VERIFY OK: nsCertType=SERVER
    Mon Oct 19 15:51:54 2009 VERIFY OK: depth=0, /C=AT/ST=xxxxx/O=xxxxx/OU=IT/CN=xxxxx
    Mon Oct 19 15:52:55 2009 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Mon Oct 19 15:52:55 2009 TLS Error: TLS handshake failed
    Mon Oct 19 15:52:55 2009 TCP/UDP: Closing socket
    Mon Oct 19 15:52:55 2009 SIGUSR1[soft,tls-error] received, process restarting
    Mon Oct 19 15:52:55 2009 Restart pause, 2 second(s)
    Mon Oct 19 15:52:57 2009 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
    Mon Oct 19 15:52:57 2009 LZO compression initialized
    Mon Oct 19 15:52:57 2009 WARNING: normally if you use –mssfix and/or --fragment, you should also set --tun-mtu 1500 (currently it is 1400)
    Mon Oct 19 15:52:57 2009 Control Channel MTU parms [ L:1442 D:138 EF:38 EB:0 ET:0 EL:0 ]
    Mon Oct 19 15:52:57 2009 Data Channel MTU parms [ L:1442 D:1442 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
    Mon Oct 19 15:52:57 2009 Local Options hash (VER=V4): 'a6ae7d69'
    Mon Oct 19 15:52:57 2009 Expected Remote Options hash (VER=V4): '006a55ce'
    Mon Oct 19 15:52:57 2009 Socket Buffers: R=[8192->8192] S=[8192->8192]
    Mon Oct 19 15:52:57 2009 UDPv4 link local (bound): [undef]:1194
    Mon Oct 19 15:52:57 2009 UDPv4 link remote: xx.xx.xx.xx:1194
    Mon Oct 19 15:52:57 2009 TLS: Initial packet from xx.xx.xx.xx:1194, sid=4f1a09e4 99dd855c
    Mon Oct 19 15:52:57 2009 VERIFY OK: depth=1, /C=AT/ST=xxxxx/L=xxxxx/O=xxxxx/OU=IT/CN=xxxxxCA/emailAddress=xxxx@xxx.com
    Mon Oct 19 15:52:57 2009 VERIFY OK: nsCertType=SERVER
    Mon Oct 19 15:52:57 2009 VERIFY OK: depth=0, /C=AT/ST=xxxxx/O=xxxxx/OU=IT/CN=xxxxxx

    Das Icon wird gelb und versucht immer wieder eine Verbindung aufzubauen.
    Meine Pfsense läuft auf 1.2.2 auf einem Alix Board
    Ich habe auf dem gleichen Board schon die Monowall am laufen gehabt und hier hat die Verbindung super funktioniert.
    Hab am Client auch nichts geändert und alle anderen Verbindungen auf meinem IPCOP funktionieren auch.

    Kann mir jemand sagen was hier der Fehler sein könnte ?

    Vielen DAnk schon mal

    cu
    mandragora :D :D :D



  • Hallo Leute,

    Es hat sich alles geklärt.
    Es hat da Probleme mit den Zertifikaten am IPCOP gegeben.
    Die wurden von mir korrigiert und nun funktioniert es wieder.
    War zuerst ein Irrglaube von mir das es an der Pfsense lag.

    lg
    mandragora :D :D :D


Log in to reply