PfSense 1.2.3-RC3 does not support squid delay_pool



  • Hi
    squid in pfSense 1.2.3 doesn't seem to have delay_pool compiled.
    The other thread http://forum.pfsense.org/index.php/topic,20001.0.html might be the same problem. (I don't read Indonesian, but it looks like it)

    squid -k parse

    2009/10/23 10:12:16| parseConfigFile: squid.conf:64 unrecognized: 'delay_pools'
    2009/10/23 10:12:16| parseConfigFile: squid.conf:65 unrecognized: 'delay_class'
    2009/10/23 10:12:16| parseConfigFile: squid.conf:66 unrecognized: 'delay_parameters'
    2009/10/23 10:12:16| parseConfigFile: squid.conf:67 unrecognized: 'delay_initial_bucket_level'
    2009/10/23 10:12:16| parseConfigFile: squid.conf:70 unrecognized: 'delay_access'
    2009/10/23 10:12:16| parseConfigFile: squid.conf:71 unrecognized: 'delay_access'

    squid -v

    Squid Cache: Version 2.7.STABLE7
    configure options:  '–bindir=/usr/local/sbin' '--sbindir=/usr/local/sbin' '--datadir=/usr/local/etc/squid' '--libexecdir=/usr/local/libexec/squid' '--localstatedir=/usr/local/squid' '--sysconfdir=/usr/local/etc/squid' '--enable-removal-policies=lru heap' '--disable-linux-netfilter' '--disable-linux-tproxy' '--disable-epoll' '--enable-auth=basic digest negotiate ntlm' '--enable-basic-auth-helpers=DB NCSA PAM MSNT SMB LDAP YP' '--enable-digest-auth-helpers=password ldap' '--enable-external-acl-helpers=ip_user session unix_group wbinfo_group ldap_group' '--enable-ntlm-auth-helpers=SMB' '--enable-negotiate-auth-helpers=squid_kerb_auth' '--with-pthreads' '--enable-storeio=ufs diskd null aufs coss' '--enable-ssl' '--with-openssl=/usr' '--enable-pf-transparent' '--enable-err-languages=Armenian Azerbaijani Bulgarian Catalan Czech Danish  Dutch English Estonian Finnish French German Greek  Hebrew Hungarian Italian Japanese Korean Lithuanian  Polish Portuguese Romanian Russian-1251 Russian-koi8-r  Serbian Simplify_Chinese Slovak Spanish Swedish  Traditional_Chinese Turkish Ukrainian-1251  Ukrainian-koi8-u Ukrainian-utf8' '--enable-default-err-language=English' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' '--build=i386-portbld-freebsd7.0' 'build_alias=i386-portbld-freebsd7.0' 'CC=cc' 'CFLAGS=-O2 -fno-strict-aliasing -pipe -I/usr/local/include  -I/usr/include -DLDAP_DEPRECATED' 'LDFLAGS= -L/usr/local/lib -rpath=/usr/lib:/usr/local/lib -L/usr/lib' 'CPPFLAGS='



  • I ended up compiling squid from source with –enable-delay-pool option and copy the binary to pfsense box and it seems to be working.



  • its not pfsense. its in squid package it self that was being compiled without delaypool enabled.


Log in to reply