1.2.3-RC3 using slbd ?



  • Hello!

    I migrated one pfSense today

    **** from 1.2-BETA-1-PRERELEASE-SNAPSHOT-04-23-07 embedded
    **** to 1.2.3-RC3 built on Thu Oct 22 05:53:52 UTC 2009 nanobsd

    I changed the CF and I loaded my config.xml backup. Everything ok, but at

    Diagnostics: System logs: Load Balancer

    I can see:

    Oct 23 17:39:46 	slbd[420]: Using configuration file /var/etc/slbd.conf
    Oct 23 17:39:46 	slbd[420]: Using r_refresh of 5000 milliseconds
    

    I don't use load balancing with this box. I used sometimes but now I don't have any pool defined.

    At console I see:

    #  ps -aux | grep slbd
    root   15697  0.0  0.4  3244  1040  ??  Ss    6:26PM   0:00.03 /usr/local/sbin/slbd -c/var/etc/slbd.conf -r5000
    root   19771  0.0  0.5  3364  1168  p0  S+    6:40PM   0:00.01 grep slbd
    

    How I can clean my new version?

    I think the problem is that I have one misterious empty pool. Please see attachment.

    I can't find the way to remove it.

    Regards,

    Josep Pujadas




  • Modify /cf/conf/config.xml and find the empty tag.  Might be called slbd or lb or somethings similar.

    rm /tmp/config.cache after your modification.



  • Scott,

    I have this code at config.xml file:

    <load_balancer><virtual_server></virtual_server></load_balancer>

    It's not possible to modify the file at console because when I exit vi with !wq I got File modified since last write. and next the pfSense menu …

    I found a similar problem with OpenVPN Client. I have also an empty tag:

    I suppose I have to erase these lines. I will backup config.xml on a separate machine, edit and restore ...

    Many thanks,

    Josep Pujadas



  • I suppose I have to erase these lines. I will backup config.xml on a separate machine, edit and restore …

    Done!

    Working without logs about slbd and openvpnclient …

    Josep Pujadas


Log in to reply