LAN/WAN never work at the same time



  • Alright so after ton of configurations, I've only managed to get LAN or WAN working separately, never at the same time.

    I'm using VMware workstation 6.5 with pfSense 1.2.2

    I have Host Virtual Network Mapping set to:
    VMnet0 - Onboard NIC
    VMnet1 - LAC3 (VMnet1) - default
    VMnet2 - PCI NIC
    VMnet3 - Wireless NIC
    VMnet8 - LAC4 (VMnet8) - default

    In the connection properties, for the Onboard NIC, I only have VMware Bridge Protocol selected
    For the other connections, I have everything selected.

    So far, the most I've really been able to do is access the GUI when the pc is connected to the WAN port, and the WAN address is an address that would be assigned by LAN.
    I've gotten it to detect an actual WAN ip a couple times, but when it did and I tried to access any WAN settings in the GUI, it would stop loading until I went to a different page..

    I've got the windows firewall off on all networks.

    What could be wrong here?



  • It sounds like a VMWare configuration error.  Which VMWare network have you connected to your WAN and which to your LAN?  Have you configured VMWare to pass those to pfSense accordingly?



  • My WAN is eth0, set as a Other (VMNet0). Eth0 should be the onboard nic, so that's what I have it connected to.
    The LAN is eth1, set as bridge.

    I think it might be an issue with the NIC's themselves or the router's having problems with them.
    I decided to try simply getting online on the PC using each of the NIC's.
    Originally, the onboard NIC worked. But when I switched the ethernet cord to the other NIC's, I kept getting 169.* ip's. Went back to the onboard NIC and got a 169.* ip as well..



  • What is the LAN interface bridged with - if it's bridged with the onboard NIC I'm not surprised you're having problems.



  • I've tried every setting there is in VMWare and it still doesn't work properly.



  • You failed to answer my question.



  • Which bridge do you mean?

    In pfSense, it's em1, which is currently set as NAT in VMWare.. But I've tried Bridge, and Custom with VMnet1 and 2 with the same results..



  • Ok, let's do a little basic networking - does your VMWare host have 2 physical network interfaces?



  • Yes



  • Is one connected to your WAN and one to your LAN.

    Are your WAN and LAN physically separate networks with different IP ranges?



  • WAN is connected to my router (192.168.1.)
    LAN is connected to a netbook I'm using for testing (192.168.2.
    )

    I've actually managed to get it working.
    I was using 3 NIC's, but when I disabled one and set WAN to VMnet0 and LAN to VMnet4 (For some reason, I can't assign the PCIE NIC to anything in the Virtual Network Editor) and pfSense is reporting a valid IP from the router and I'm able to access the gui from the netbook, but I can't route further with it.

    So I decided to test it going directly from the modem. And it failed to renew the IP. So I connected it back to the router, and it's once again assigning itself one of it's own LAN ips.


Log in to reply