How to RDP to a computer that is connected to 2nd DHCP in 2nd network

  • Hello All,

    I am new to PFSENSE and new to firewalls so take my appologies for something that is easy for YOU.

    I have scenario:

    LAN–- WIFI router with DHCP ----- WIN2003 Server

    From the network I cannot access WIN Server uisng RDP 3389 port. How I can achieve this?

    Another think how can I access WIN Server from WAN (outside) using RDP?

    Take my appologies one more time if this is trivial for you.


  • Is the pfSense this WIFI router?
    What interface is the ? The WAN? or an OPT?
    Or is the WIFI router a different standalone device with the LAN of the pfSense connected to it's WAN?

    1. Forward 3389/TCP on the WiFi router to the Win2K3 server, having ensured that the Win2K3 server has a static IP address.

    2. Forward 3389/TCP on the WAN router/firewall to (the WiFi router)

  • WIFI router is not PFSENSE WIFI. This is just Trendnet Router hooked to network that has IP. This device has it's own gateway and it's own network

    I know I should have added another NIC to PFSENSE and name it OPT1 - then it would even be place as DMZ or whatever just WIFI to be isolated from the rest of the natework.

  • Thank You Cral Havok.

    regarding 2) Forward 3389/TCP on the WAN router/firewall to (the WiFi router) - yes I did that rule in firewall but I am not able to RDP that server from the LAN. I cannot ping network from

    Is there static route needs to be created ?


  • Try RDPing to instead - if you've left the WiFi router doing NAT you won't be able to route to the network.

  • I can RDP that ( server from LAN; however I cannot RDP from outside WAN

    MY NAT:

    WAN  TCP  3389 (MS RDP) 3389 (MS RDP)


    TCP  *  *  3389 (MS RDP)  *

    And LAN rules:

    *  LAN net  *  *  *  *

    Still not able to rdp from WAN.

  • If you can RDP to the IP then it suggests that your WiFi router is only routing and not doing any NAT.  You need to change your port forward and rules to reflect the IP accessible from the LAN -

  • OK, lets forget about RDP throught WiFI router with enabled DHCP.

    Simply I added port forwarding with Firewall rules to one of my desktops(yes I have enabled RDP in Windows XP prof. adding one user to RDP list) Now I can RDP from inside LAN but from WAN no. This was pretty easy on any devices like linskys, etc…. Why the simple think does not want to work with such amazing soft firewall like PFSENSE? I want to believe that I made some "user errors" not the soft. I will be fallowing another guide example from net.

    I have to add I just simply copied rules from ENDIAN firewall that so far work pretty nice. I don't want to believe that I have to reboot PFSENSE in order to get it works after made any changes to rules. What I do wrong that simple RDP is not working?


  • Does the pfSense host know how to route to the network?  If not, how do you expect it to know how to forward packets…

  • Should it looks like this:

    ![Static Route.JPG](/public/imported_attachments/1/Static Route.JPG)
    ![Static Route.JPG_thumb](/public/imported_attachments/1/Static Route.JPG_thumb)

  • If is the gateway to the network then yes.  However you've previously posted that is the gateway.

  • I am sorry - my bed. is IP address of WiFI Router

    WAN –--- PFSENSE ---- Wifi Router (DHCP) Gateway ------- WINSERVER (Static IP)

    Should't I be able to ping from network ? after setting static route to ?

  • What IP addresses does the pfSense host have?  What IP addresses does the WiFi router have?  Please complete the following with the real IP addresses (if IP A is your real WAN IP then replace it with WAN):

    WAN –-- IP A (pfSense) IP B ----- IP C (WiFi) IP D --- WinServer (

  • WAN –-- (pfSense) ----- (WiFi) --- WinServer (

    PFSENSE has GW and it's DHCP

    WiFI ROuter has GW and its DHCP

    WiFi is simply connected to network

  • Hopefully you're confused about those gateway addresses.  The gateway address is the address of the device that connects to other networks.

    For the pfSense host the gateway (default route) should be being set by DHCP.  There should be a static route for with a gateway of

    For the WiFi host the gateway should be

  • OK so that was user error I mean my ….  :-\

    I have been trying to experiment with static routes and after I added to and to
    my whole network went down and DHCP on WiFi router has been changed from to

    I am trying to figure it out why that happend.

    Thank You for Your help. Every message make me closer to what I messed up.


Log in to reply