SMTP Rules ?



  • Hello

    I simply want to send a mail with Thunderbird.
    My provider give me the adresse of the imap server to synchronyse mail and the SMTP server to send mail.
    I add a rules for Imap (port 143) and can synchronise my mails.
    I add a rules for SMTP (port 25) but i can't send mail (the packet go outside but nothing else).
    Telnet say that there is a time out on the SMTP server. (I try a telnet from my office and the SMTP server of my provider is OK).

    I think i missed something in the configuration of PfSENSE  ?

    I hope i am clear in my frenchy english.  Need Help.



  • Please show us your firewallrules. It's hard to say anything without seeing them.



  • I have a WAN and a LAN

    My 2 rules

    Proto  Source      Port  Destination  Port      Gateway    Description

    TCP 192.168.10.200  *      *             25 (SMTP)     *           SMTP

    TCP 192.168.10.200 *     *             143 (IMAP)     *           Imap

    My computer is the 192.168.10.200



  • These rules are both at LAN? Traffic from your client happen both going from LAN to WAN, so they both should be at the LAN interface. No need for a rule at WAN for this to work. Am I right that you deleted the default LAN->any rule? Also make sure your rules have the correct order in case you have other rules on top. First match wins. Finally, do you see blocks in your firewalllogs at status>systemlogs, firewall?



  • Ok thanks,

    I have :
    -My both rules are only in LAN.
    -I see 1 block in firewall logs and the rules is green (destination : mySmtpProviderIp:25 ).

    At home, Telnet always say that there is a time out on the SMTP server of my provider .
    I am in my office and i can connect with telnet…

    I will try (at home) :

    • to reorder rules (by port)
    • to allow all traffic  (default LAN->any rule)
    • to test with another computer on my lan (perhaps a bug of windows?)

    See you.



  • Well…

    i reorder rules (by port)
    i allow all traffic  (default LAN->any rule)
    i test with another computer on my lan
    i desactivate local firewall (kerio) and antivirus (avast)

    Always the same problem

    I try to connect with the cmd :  telnet mail.club-internet 25    and then try to connect other smtp server with no sucess

    Do you connect to smtp server ? and what is your configuration ?

    PS : i have a poor value for  : interfaces WAN>General configuration> MTU (=750) . perhaps this is the problem ?



  • telnet mail.club-internet.fr 25 
    works here on a virgin pfsense rc2g version whith default rule on lan



  • @jeje:

    Do you connect to smtp server ? and what is your configuration ?

    SSH in your pfsense box, open a telnet session (after hitting option 8 ) like this:
    telnet yoursmtp 25

    Your smtp server should be mail.club-internet**.fr** 25

    I could connect to it (plain vanila pfsense dev edition).

    PS : i have a poor value for  : interfaces WAN>General configuration> MTU (=750) . perhaps this is the problem ?

    You should bring this up to 1452 (for a PPPoE connection) or even somewhat more.



  • Argggg….

    I upgrade RC1 to RC2
    Put my mtu to 1452

    Install Putty and SSH and launch a telnet session

    telnet mail.club-internet.fr 25 
    telnet smtp.wanadoo.fr 25    ....

    all connection to smtp server are refused in the ssh console

    Does it means that my modem has some troubles  ??????????  (i have a ADSL ethernet BEWAN modem)

    Any idea ?



  • @jeje:

    (i have a ADSL ethernet BEWAN modem)

    This modem, is it in PPPoE mode or router mode ? (You should prefer PPPoE - so the pFsense box has the Internet IP on its WAN)
    If you hook it up to a PC - can you telnet 'to the world' from your PC ?



  • I am in PPPoe mode
    I connect my modem directely to a computer and i cannot connect to smtp …

    It is not Pfsense, it is something else... :-\

    I don't understand why my PPPoe Modem cannot do connection to SMTP.

    Any other suggestions will be appreciated....

    I am going on google and try to find a solution (upgrade my ugly modem ?)

    Thanks.



  • :D  find the solution

    My modem is not ugly

    My provider is ugly ;D  (tele2)

    it refuses all connection to smtp server except for its smtp server (smtp.tele2.fr)  .

    Sorry for the problem.

    thanks all.


Locked