• i have been using the 14th november nanobsd image on alix but from past few days i have no idea whats wrong but wireless clients can associate, get ip but no data flows so wireless clients r not able to surf, was working fine few days back so can some1 kindle help me diagnose the problem?

  • what chipset wifi?  they recently (around nov 1st or so?) changed the ath driver from 7.1 to 7.2 and that has caused stability issues for many here (including me).  search for that - their reasoning was that the patched 7.1 did not support some boards/chipsets.

  • The old driver caused more problems than it fixed, though for a few switching back caused more problems than before. What's there now will be what's in the final release. See also

  • i have the atheros chipset, i guess 5214 or something like that, i got 2 atheros wifi card both have problems, can any1 tell me which snapshot doesnt have that update, simply might switch to that for time being?

    frankly speaking it was working fine for me for the 1st and 14th nox snapshot but just since yesterday it started having issues, it associates, hands out ip but while surfing, a little data passes and then stop, then after some while again it passes and stop.

  • on further testing i see that packets from wireless clients reaches the firewall but from firewall to wireless clients nothing goes or goes only sometimes, i havent touched my firewall and traffic shaper rules from months then y is this happenning?

  • well, i've had it with atheros.  i have also tried the older kernel, and i am still having wireless issues.  what happens is that not all of the wifi clients drop off the air, just one particular one.  i seem to recall someone mentioning ralink?  or maybe i should just punt on this and get up another WAP to put on the LAN?  this is beyond annoying :(  Also, when this happens, I can ifconfig ath0 down and up and that doesn't fix anything.  I can also tweak other wireless parameters (I haven't tried everything) and nothing helps except rebooting the pfsense gateway, which is obviously suboptimal :(

  • Rebel Alliance Developer Netgate

    If only one client drops off, have you investigated any possible issues with that client?

    Seems weird that you have to completely reset pfSense to let it reassociate, but that doesn't mean that it isn't something the client is doing to make that happen.

  • i suppose it could be, yes.  on the other hand, i have also had the issue where everything stops working too.  the client in this case is a buffalo-tech router flashed with dd-wrt in client bridge mode.  i have taken a screenshot when it is okay, and if/when this happens again, i will check to see if it is even associated.

  • basically my setup was working fine since so many days but now all my clients can conenct and associate but no data transfer so i moved to the older snapshot in which it started working but cant get my iphone to surf, no idea what went wrong coz there wasnt any config change ever.

  • i just installed the 29th November, same thing happens but what i also suspect is there r 2 traffic shaping rules which might also be affecting, screen shots below, if these rules remain on top of list then iphone cant surf at all but if they remain below the list then it can but barely which means i don't have an issue with the drivers or so nor does systemlog show anything weird but what i also saw was on my system page the CPU usage always remains 100%, either its a cosmetic bug or something else is wrong coz using 'top' i didn't see any process causing such high CPU usage.

    keep in mind iphone is not using ip shown below, it uses and wireless is bridged LAN

  • 100% cpu usage is due to device polling so disabled that and solved it

    one more finding:
    if i disable traffic shaper everything works like a charm but with it enabled, doesnt

    if wireless is bridged to LAN and if u need to have traffic shaping rules for wireless then packet in interface to select will be WAN as usual but out interface needs to be LAN (due to wireless being bridged to LAN) or opt1 (wireless) ?

    above question is relevant if traffic shaping is possible on bridged interface