Openvpn client - routing issue



  • My work uses Openvpn for us to vpn into the office.

    Office is 192.168.0.0/24

    VPN tunnel is 10.10.0.0/24

    Home is 192.168.1.1/24

    I setup the openvpn client in PFsense it seems to work great.  Directly form the pfsense systemI can ping ssh to office network.  But not from my computer behind the pfsense.

    I believe I need to setup a outbound nat rule. But here I am getting a bit confused.  Source and destination IP's.  Atleast believe that is my issue.





  • I must be misssing something here.  Setup outbound nat.

    192.168.1.0/24 to 192.168.0.0 and tried to 10.10.0.0 neither seems to setup the nat properly.



  • Can you please show a screenshot of your AoN rules?



  • Interface  Source  Source Port  Destination  Destination Port  NAT Address  NAT Port  Static Port

    LAN    192.168.1.0/24  *          10.10.0.1/32  *                      *                *          NO
    WAN    192.168.1.0/24  *  *  *  *  *  NO

    Is the line I have tried using.  I swear I got it to work other day.  But when checked later was not working.



  • Your First rule is wrong.
    The interface should be the virtual openVPN interface and not the LAN interface.
    Did you assign the openVPN interface as described in the link above?
    Also as destination you dont want /32 but /24
    additionally you need another rule for the office subnet.



  • I just tried changing that other day for hell of it was /24.

    That def is a prob did not assign tun0 to interface.  I read that but when go to assign interface it just shows le0, le1 and plip nothing else.

    Thank you for the help.



  • I just did the upgrade to 1.2.3.  The tun interface is assigned to opt1 setup the routes and works perfectly.

    Thanks again for the help.


Log in to reply