Problema VPN varios clientes



  • Hola a todos, vereis tengo un pfsense, concretamente la version 1.2.2, y tenog el siguiente problema.
    En mi red, hay dos usuarios que intentan abrir una conexion VPN a una maquina externa, el problema que veo, es que los dos a la vez no pueden conectarse (seguro que no es configuración del otro extremo, el problema está en mi red por lo que ovy a explicar), uno si que puede, cualquiera de los dos, pero a la vez no.

    La VPN a la que necesitan acceder es PPTP sobre TCP… y mi problema creo que llega con el GRE, tengo entendido que esta versión no permite varios usuairos en la red con este tipo de VPN, sabeis si se soluciona actualizando a la 1.2.3? que puedo hacer si no? muchas gracias por adelantado.



  • ¡Hola!

    El código de PF (Packet Filter) para el protocolo GRE sólo soporta una única sesión por IP pública.

    Para salir afuera no hay que hacer NAT Outbound (tal como pone en la pantalla de NAT Outbound) para GRE y entonces se podrá ir a varios servidores PPTP externos. Pero dos clientes internos tampoco pueden ir a la vez a un mismo servidor PPTP externo.

    No sé cómo está esto en otros sistemas operativos pero había manejado alguna vez PPTP con Windows 2000 Server y era lo mismo.

    Saludos,

    Josep Pujadas



  • Gracias por la contestación Bellera… la verdad es que es un poco jod.... a ver que puedo hacer para solventarlo



  • rebuscando un poco parece que si que es posible aunque la dirección IP y el puerto de destino es el mismo, en la tabla de traducción del NAT del Firewall la IP/puerto del origen es distinta, con lo que de cara al servidor de túneles son dos conexiones distintas realizadas desde la misma ip, una por un puerto, otra por otro (de origen)… El problema es cuando el protocolo del que se hace nat es nativo sobre el ip (ej. gre, esp, etc) Normalmente los Firewalls de soft esto lo llevan mal y hay que tunearlos.... así que me temo que estoy algo fastidiado en el tema... alguien puede arrojar algo de luz?



  • Hola buenas , tenia un problema al intentar acceder por la Vpn a maquinas por samba , se soluciono el problema con upgrade de la version 1.2.2 a la 1.2.3 , va de cine.
    Saludos


Log in to reply