OpenVPN kills WAN and LAN connections



  • I am running pfSense 1.0 RELEASE CANDIDATE-2.  When I attempt to configure OpenVPN, according to http://doc.pfsense.org/index.php/Setting_up_OpenVPN_with_pfSense, both WAN and LAN connections die when I test connecting to it.  I do make a connection because I pull an IP on the correct subnet, but it kill the both connections so I can't do anything once I am connected.  Strange, and thoughts?





  • Thanks.  Do I pull down the Full-Update?



  • If you installed from an ISO, that is a "FULL" install so yes.



  • well….that kind of worked.  I was able to connect from Windows, but when trying from my Ubuntu install it hosed up the LAN connection.  The WAN appears to be fine.  I was able to ping an external host (google.com).



  • Define "die", "hose". They simply stop responding?

    We'll need more info about your setup. IPs, gateways, maybe the config.xml part regarding OpenVPN, and also /var/etc/openvpn* (except for your keys, obviously).



  • Well, uh, die…hosed...as in not working or responding.  Anything on the LAN you can't ping.  The only way I can bring it back is to reset to defualt and load my backup config.  As I said before, I am trying to set it up simular to this: http://doc.pfsense.org/index.php/Setting_up_OpenVPN_with_pfSense

    LAN Subnet: 192.168.0.1/24
    WAN: DHCP
    OVPN: 192.168.1.1/24

    config.xml

    
     <openvpnserver><config><disable><protocol>UDP</protocol>
                                    <dynamic_ip>on</dynamic_ip>
                                    <local_port>1194</local_port>
                                    <addresspool>192.168.1.1/24</addresspool>
                                    <nopool><local_network><remote_network><client2client><crypto>BF-CBC</crypto>
                                    <auth_method>pki</auth_method>
                                    <shared_key><ca_cert>*left out*</ca_cert>
                                    <server_cert>*left out*</server_cert>
                                    <server_key>*left out*</server_key>
                                    <dh_params>*left out*</dh_params>
                                    <crl><use_lzo>on</use_lzo>
                                    <custom_options><description>Home VPN</description></custom_options></crl></shared_key></client2client></remote_network></local_network></nopool></disable></config></openvpnserver> 
    
    


  • Still having the same problem.  I have updated to the latest snapshot (09-20-06) and it seems the plus button to assign new interfaces is no longer there.



  • Nothing openvpn GUI wise has changed at all for months…  Not sure why the + button would disappear.



  • This is going to sound dumb, but just reload.  Seriously.

    I've had this bug occur on firefox on various platforms depending on what extensions I have installed.  Reload, disable NoScript, whitelist the site in Adblock, do whatever you have to do to make sure javascript executes, etc etc etc.

    It'll come back.  If not, try leaving some cat food out on the front porch.  Maybe it'll find it's way home then.  ;D


Locked