Traffic shaper issue with wireless bridged to lan



  • what do your rules look like?



  • below r the rules






  • so where is the opt1 (wifi) rules described?



  • I don't see anything that would make LAN traffic any different from wireless traffic.  In fact, I don't see what you mean when you say that LAN traffic is being shaped properly - it looks like port 80 should go on default queue regardless.  What are you trying to shape to what queues?



  • @xaviero:

    so where is the opt1 (wifi) rules described?

    If wireless is bridged to LAN, he shouldn't need any.



  • basically this is the default config and i want this to work for wireless clients also, now if i add wireless rules as in wan to wireless then till then wireless will go to queues i add but on reboot of the alix then no wireless client will be able to surf, they get ip from dhcp but no data transfer so if i have wan to opt1 and opt1 to wan rules that makes all data transfer for wireless clients stop.

    i read on some older posts that if wireless is bridged to lan then those lan rules r supposed to apply for wireless also as the lan interface is the one giving out ips to wireless.



  • Correct, as far as I know (not wireless rules needed.)  That said, can you describe what you are trying to do?  (e.g. what traffic and what queues?)



  • basically i want the wireless bridged to lan to  follow the same queues i have added for lan but thats not the case, whatever i do from wireless goes to the default queue not the ones i have added which work perfectly for LAN



  • i want the default queue for p2p traffic and works for lan clients but not for wireless bridged to lan



  • You still have not described what traffic you are trying to put into what queues.  Without that it is hard to help you :(



  • wtf?  first you say you want p2p traffic in the default queue for lan and then you complain that wireless is going in the default queue, unlike lan.  ???????



  • all lan http traffic goes to qlandef/qwandef as i want it

    but all wireless http traffic doesnt go to qlandef/qwandef but it goes to the default queue, qP2PUp/qP2PDown



  • Oh, eek.  I just noticed you have the P2P queues set as default?  Why???  the landef and wandef queues are normally the default queues - who knows what you are breaking by changing that.  The shaper wizard has all kinds of settings for P2P - do those not do what you want?



  • basically i had ran the wizard the first time i used pfsense then did a lot of modifications manually and i want higher priority for web, mail etc as u see from rules and rest all go to low priority p2p default queue.
    i read long time back in some post that just putting things i want to run smooth in higher priority and leave the less as default will result in all p2p going to default queue being a way to properly route actual torrent traffic to lowest priority and i prefer to use it this way.



  • the reason for this is bcoz u never know what port the client might use for torrent as its no more limited to set of ports



  • but, if you only have a couple of services that need higher priority, prioritize those, don't go screwing with the default queues.



  • like u said, i also have no idea what might break changing the wizard rules but according to the web interface, any1 can modify any rule or even create ones as they like so i doubt if any extra settings r stored along with the wizard created queues and rules.



  • well, look, you are getting free help here.  if you are not willing to take the advice, good luck to you.



  • whats the reason for being so rude, all that i said is if the wizard were to be used only then y the option to add and remove rules would be there, doesnt make sense so mayb any of the developers need to answer this that modifying the default wizard created rules for traffic shaping affect the shaper in any way, as in break it or no?



  • Same problem as OP, on an ALIX 2d3 w/ internal WiFi adapter and using PfSense 1.2.3 Final:  Wireless traffic on bridged OPT1 to LAN does not seem to get shaped by any of the LAN rules but default using the Traffic Shaper GUI / Wizard.

    I can probably fix it manually if there is a way to use 'ANY' interface where the rules choose "LAN"?  For example instead of WAN -> LAN I could use WAN -> * except that I can't do that in the GUI.  Perhaps I can edit a config file and it'll work that way?

    As a test, I coped a bunch of the rules that were LAN -> WAN or WAN -> LAN and replaced the "LAN" setting with the adapter "Opt1WiFi" (my WiFi interface name) and now the WiFi traffic is being shaped as expected.  I'm not sure if this is as designed or a problem though but for now it seems to be working OK–but at the very least, it makes rule management a major hassle.



  • if u set wan to opt and opt to wan then that will work only till a restart.
    try switching to 2.0


Log in to reply