Ath0: stuck beacon; resetting (bmiss count 4)



  • I keep getting tons of errors with my wireless card. Its a 802.11n card but I was able to get it work on pfsense 1.2.3-RELEASE as a 801.11g card.

    It seems to be working good, but there's tons of errors:

    ath0: stuck beacon; resetting (bmiss count 4)
    ath0: stuck beacon; resetting (bmiss count 4)
    ath0: stuck beacon; resetting (bmiss count 4)
    ath0: stuck beacon; resetting (bmiss count 4)
    ath0: stuck beacon; resetting (bmiss count 4)
    ath0: stuck beacon; resetting (bmiss count 4)
    ath0: stuck beacon; resetting (bmiss count 4)
    
    

    Basically, that over and over again. Is this something to be worried about? Is there any way I can make it so that I won't get the errrors?


  • Rebel Alliance Developer Netgate

    It's hard to say. That tends to vary from card to card (and sometimes a client/card combination)

    If you aren't noticing any client drops or packet loss, it may not be much to worry about.



  • Thanks for your reply.

    I've been testing the wireless for a while now. It seems to me like the signal is very strong (100%) sometimes and then weaker other times. There's been times that even though the computer is 20ft. away, its been giving a weaker signal than our other wireless router that is at least 50 ft away. Plus I noticed that it drops the connection from time to time.

    I'm kind of curious if maybe these problems are or will be fixed in pfsense 2.0. This card is after-all a 802.11n card and pfsense technically doesn't support those even though I got it to work in 802.11g mode. And its a really good card too… a TP-Link 300Mb/sec, extended range... two antennas, etc. It even has the atheros chipset which apparently is supposed to work really good on pfsense.

    Thanks for your help.



  • I installed the pfsense on an old asus eeepc 701. shows to work fine so far. two clients connect and go to the internet without any load on the small machine.
    i keep receiving the same messages like cited by you:

    kernel: ath0: stuck beacon; resetting (bmiss count 4)

    i would be very interested in information about good hardware (antennas) - if this really is the problem.

    greetz



  • the problem got worse after activating some modules and trying to activate traffic shaping…

    surfing the web i found, that it might be a bsd 7.2 problem - hardware related:

    i show excepts from: (Is this correct? :S)

    http://groups.google.com/group/mailing.freebsd.current/browse_thread/thread/5b79825ff24d4ba7

    "stuck beacon" means the ap tried to xmit a beacon frame but for various
    reasons (where "various" is VERY large) it wasn't able to.  After N
    consecutive attempts, 4 in this case) it gives up and resets the device
    (which should bring it back to life in case it's stuck because of a
    hardware bug).  Often this occurs because you are using a slow platform
    and the time provided to prepare the beacon frame is insufficient to
    push it to the hardware fast enough to meet the realtime requirements. 
    This can be exacerbated by operating on a busy channel.  Unfortunately
    you've provided very little info so I can't advise you.  I suggest you
    search for this subject and look at the discussions that have occurred
    for the last 5-6 years...

    I will try to get the load off again - even, if the machine doesn't show too much yet:

    last pid:  3793;  load averages:  0.16,  0.16,  0.19            up 0+00:27:07  00:05:04
    64 processes:  1 running, 63 sleeping
    CPU:  0.4% user,  0.0% nice,  1.5% system,  0.0% interrupt, 98.1% idle
    Mem: 112M Active, 25M Inact, 37M Wired, 32K Cache, 28M Buf, 307M Free
    Swap: 512M Total, 512M Free

    two clients accessing and downloading with approx. 700KBs



  • Yes, I've read that thread. Hopefully this problem will be solved in pfsense 2.0. I do not think I will test out pfsense 2.0 for at least a couple weeks from now. Maybe a month or so. But, hopefully it will be solved then.

    I'm also thinking about getting a couple better quality antennas. The ones I have are not that great.

    Right now the wireless doesn't even work when I've placed the router where it goes… its too weak of a signal.


Log in to reply