Dashboard issues



  • I did a clean install of 2.0 beta 1 12/26 and the dashboard isn't allowing me to add widgets it adds widget but just get a spinning circle and the save button never shows up also can't drag (relocate) widgets tried with different themes same problem


  • Rebel Alliance Developer Netgate

    With what browser?



  • I tried 3 firefox 3.5.6  ie 8 and google chrome 4.0



  • same here and my dashboard never refreshes, tried firefox latest and IE6



  • the same question! :'(



  • Same here, My trick to load it is

    add widget (shows a widget with no details)
    minimize then restore widget window ( allows to appear "Save…" )
    click Save.

    When it reloads, it now shows the new widget.

    This needs fix.

    Also, widgets aren't moveable.


  • Rebel Alliance Developer Netgate

    Of course it needs fixed :)

    But please remember you are still using a BETA, and be kind and patient.

    If there is no existing ticket on http://redmine.pfsense.org then one should be opened with as much detail as possible.


  • Rebel Alliance Developer Netgate

    I opened two tickets for these separate issues:

    Scriptaculous update broke dashboard drag & drop
    http://redmine.pfsense.org/issues/show/250

    Unable to add Dashboard widgets
    http://redmine.pfsense.org/issues/show/251



  • Hey jimp, do you have any idea how long such a dashboard fix should take? From what I can see the d&d issue has not been applied to a dev. Is this because it is not a major issue?


  • Rebel Alliance Developer Netgate

    I'm not sure. I'm no javascript guru by any means, so I have no idea if the fix for the drag & drop problem will be to back out that update or to fix the code so it works with the new javascript library.

    Given that it's still vacation for many people, it may be a while before anyone gets a chance to seriously look at it.



  • The Scriptaculous should now be fixed and I can re-arrange my widgets. But I cannot move them back to the right site of the screen. I can only arrange them on the left site from top to bottom. Any info on how to "reset" the dashboard to default?


  • Rebel Alliance Developer Netgate

    On a system running a snap from yesterday and then gitsync'd to current code I can empty out a column and then save and then put things back.

    I can also add widgets fine again. cmb fixed the issues as far as I can tell.



  • Well, I can do all that but I cannot change the column. Here is a screenshot. If I try to move the interfaces widget to the right it just snaps back below the system information.




  • In Firefox, Im only seeing this if I let go too soon when dragging.  Seems to be how its always worked.  No issues here as well.



  • Doesn't matter how long I drag…

    FF 3.5.7 or with Safari 4 at home...

    How can I completely reset the dashboard? Anything I could do on console?



  • Tried again. Removed all widgets, saved and then added two widgets, saved again and tried to move one widget to the second column but it doesn't work :-(


  • Rebel Alliance Developer Netgate

    This is what I have in my config that is working. I had added and removed and shuffled around widgets, but the only ones open are system info, firewall logs, and the traffic graphs.

    	 <widgets><sequence>carp_status-container:col1:close,cpu_graphs-container:col1:close,gmirror_status-container:col1:close,havp_alerts-container:col1:close,installed_packages-container:col1:close,interface_statistics-container:col1:close,system_information-container:col1:show,ipsec-container:col2:close,log-container:col2:show,traffic_graphs-container:col2:show,load_balancer_status-container:col2:close,openvpn-container:col2:close,services_status-container:col2:close,snort_alerts-container:col2:close,captive_portal_status-container:col2:none,picture-container:col2:none,rss-container:col2:close,interfaces-container:col2:close,gateways-container:col2:close</sequence>
    		<rssfeed>http://blog.pfsense.org</rssfeed>
    		<rssmaxitems>10</rssmaxitems>
    		<rsswidgetheight>300</rsswidgetheight>
    		<rsswidgettextlength>140</rsswidgettextlength></widgets> 
    


  • I'm using Firefox 3.7a1pre and pfSense 2.0-BETA1 built on Fri Jan 8 03:48:57 EST 2010 and my dashboard works fine. Refreshes, I can add/remove widgets and I can move them around with no problems.


  • Rebel Alliance Developer Netgate

    Yeah it should be fine now. The tickets I opened have been closed out and I have also confirmed things are working again for me.



  • Still not working for me with Firefox and build from today!


  • Rebel Alliance Developer Netgate

    What part isn't working?

    Adding? Dragging?  Or just the second column bit?



  • Second column bit is not working. I can add and also drag in one column…

    That is what I can see in my config:

    <widgets><sequence>system_information-container:col1:show,interfaces-container:col1:show,captive_portal_status-container:col1:close,carp_status-container:col1:close,cpu_graphs-container:col1:close,gateways-container:col1:close,gmirror_status-container:col1:close,installed_packages-container:col1:close,interface_statistics-container:col1:none,ipsec-container:col1:close,load_balancer_status-container:col1:none,log-container:col1:none,picture-container:col1:none,rss-container:col1:none,services_status-container:col1:show,traffic_graphs-container:col1:none</sequence>
    <servicestatusfilter></servicestatusfilter></widgets>


  • Rebel Alliance Developer Netgate

    I haven't ever been able to reproduce the second column bug. I might give it a try later with your config snippet from there.

    In the meantime, try to edit your config and change one of those col1 entries to col2 and see what happens.



  • Hey. That seems to work. And also after that I can now move stuff in the GUI. Thanks jimp!


Locked