Problemas al Enviar mail con archivos adjuntos de microsoft outlook



  • Compañeros

    Tengo este  problema
    desde un cliente Microsoft Outlook  y voy a un servidor SMTP (TCP 25) con el correo.  y se me bloquean los archivos adjuntos
    he hecho lo siguiente

    • Aumentando el tiempo de espera en la configuración SMTP de Outlook Express.
    • No tengo activando squid+squidguard
    • no tengo  Traffic Shaper.

    ¿Pero no se como crear esta reglas?

    • Revisando tus reglas en LAN.

    Mi Lan es    LAN  192.168.18.0/24 
    LAN 192.168.17.0/24

    Y una WAN para navegación Internet  200.45.190.yyy/29

    estas dos Lan ya miran mi pfsense que tiene la dirección 192.168.18.4/.24, el pfsense tengo DHCP y  squid con la red Lan
    192.168.18.0/24 y esta trabajando bien pero no me deja “enviar correos adjuntos”.
    Pero cuando saco los equipos del pfsense me deja enviar bien los correos
    compañeros  se me olvido decirles que el servidor de correo esta en la dirección 192.168.17.10/24

    Le agradezco si me pueden colaborar

    Muchas gracias

    MAURICIO NIÑO AVELLA



  • por favor si alguno sabe como solucionar me pueden colaborar

    gracias



  • por favor me puden colaborar le he trado de configurar de muchas formas y no he podido solucionar

    garcias



  • A ver vamos viendo la klabaza.

    Tienes un firewall con pfsense, al parecer solamente lo tienes como cortafuegos.
     Detras de tu pfsense no puedes enviar correos con archivos anexos.

    1; Que version de pfsense estas usando
     2; POP / IMAP? SSL o no SSL?
     3; Ya checastes los logs de pfsense para ver si esta bloqueando algo?
     4; Si puedes enviar correos sin archivos adjuntos de cualquiera de tus redes?
     5; Puedes logearte via telnet de cualquier parte de tus redes a tu servidor de correo?  
      6; Ya probastes otros clientes(thunderbird u evolution)?

    Dices que no tienes squid y abajo dice "el pfsense tengo DHCP y  squid con la red Lan" tienes o no un squid?

    Si lo tienes no lo actives.

    Tienes 2 LANS 18/24 17/24, estan cada una en su red ? o sea tienes 1 tarjeta para cada LAN?
     De cualquier lado donde lo intentes es el mismo problema?

    Esta un poco enredoso tu post, como sugerencia ser un poco mas claro, asi muchos no van a intentar ayudarte, saludos!!!



  • Periko muchas gracias por contestar

    [PREGUNTA (1)]

    Si tengo  un firewall con pfsense, versión  1.2.3-RC3  built on Mon Oct 5 22:57:46 UTC 2009

    Y no solo lo tengo como  cortafuegos. Tengo montado DHCP Y SQUID

    Tengo dos redes LAN 192.168.18.0/24 y 192.168.17.0/24 
    Y la WAN que es una publica para navegación es decir el ISP

    La red LAN 192.168.18.0/24 es la de DHCP Y SQUID

    La otra que es 192.168.17.0/24  y la dirección que tengo con figurada en pfsense es  192.168.17.4/24 es simplemente para que los usuarios puedan navegar con la dirección con figurada en el browser
    192.168.18.4: 3128  (que esta es la dirección de mi pfsense)

    Lo que hice fue una regla para que  la red 192.168.17.0/24 pueda mirar la 192.168.18.0/24 y puedan navegar los de la 17/24 no es mas
    Pero estos usuarios los de la red LAN  192.168.17.0/24 si pueden enviar archivos adjuntos utilizan  Microsoft Outlook

    Pero el inconveniente o problema qu e tengo es el siguiente los usuarios de la red 192.168.18.0/24 que reciben direccionamiento dinámico por (DHCP)
    “No pueden enviar correos adjuntos o anexos”

    [Pregunta (2) (4) (5)]

    El servidor mail  esta aparte, es un servidor de correo pop/imap, la dirección es 192.168.17.10/24, y los usuarios de la red 192.168.18.0/24
    Que se les asigna direccionamiento por (DHCP), pueden mirar el servidor de correo y pueden enviar correos normales sin adjuntos
    Pero cuando envían correos con archivos adjuntos o anexos me los bloquea

    [Pregunta (3)]

    Lo de los logs lo he visto pero casi no lo entiendo pero si voy a tratar de portearle una imagen para ver si me puedes colaborar
    Ya que como le digo no soy experto en pfsense estoy comenzando
    Y de verdad que le agradezco si me puedes colabora mil y mil gracias

    Lo otro es que no he probado con ningún otro cliente de correo ni con clientes (thunderbird u evolution)

    Ya que en la compañía don de laboro solo trabajan con Microsoft Outlook

    MUCHAS GRACIAS

    CORDIALMENTE

    MAURICIO NIÑO AVELLA

    SALUDOS…..



  • Puesde tambien ver si el squid esta causando problemas, ese amigo pone su log en /var/squid/log, cuando hagas la prueba ten a la mano este archivo para que lo abras y busques el ip del cliente, por ejemplo, si esta probando con el cliente 192.168.17.17, en el pfsense.

    grep 192.168.17.17 access.log

    Y checa si aparece los TCP_DENIED.

    Desactiva el squid e intentas de nuevo.

    Me huele a bloqueos ya sea por parte del squid o firewall.

    Saludos!!!



  • ok periko

    voy hacer esta pruebas y te cuento

    gracias muy amable

    saludo…



  • no no funciona abri puertos 25 y 110 en SQUID Y LO MISMO NO FUNCIONA NO SE QUE HCAER



  • PERIKO COMO HAGO PARA QUE FIREWALL NO ME BLOQUE LOS ADJUNTOS LA VERDA YA HICE UNAS REGLAS EN LA LAN Y NADA



  • Mira aqui simulando tu red me funciono sin problemas.

    Aqui va.

    3 nics
        nic-a –> wan
        nic-b --> lan 192.168.50.0/24  mail server(192.168.50.140)
        nic-c --> cp 192.168.49.0/24

    Mail dovecot imap puerto 143  postfix smtp puerto 25.

    Reglas por default en nic-b(lan) no modifique ninguna.

    Agregue 2 reglas en la nic-c(cp) para que permitiera el trafico hacia la nic-b.

    regla 1 permite salir cualquier maquina de la red de nic-c hacia el ip del mail-server puerto 143 tcp
        regla 2 permite salir cualquier maquina de la red de nic-c hacia el ip del mail-server puerto 25 tcp

    Fue todo, me dejo logearme, mandar correos puro texto, con archivos adjuntos, etc sin problemas.

    No squid.

    Recomendaciones:

    1; Pon a pfsense de nuevo en sus valores por default
        2; Elimina todo lo relacionado a proxy de tu outlook
        3; Agrega las reglas segun tus datos y tus puertos, no metas mas reglas solo las necesarias para esto, ya que funcione metes las que te convengan.
        4; Pruebas con maquina en la red del correo y la otra subred.
        5; Nos cuentas como te fue...

    NOTA: El firewall no tiene nada que ver en los bloqueos de los archivos adjuntos.

    Animo!!!



  • Mismo hilo que http://forum.pfsense.org/index.php/topic,20370.0.html

    ¡Por favor, no dupliquen hilos!



  • bellera desconocia el otro post, disculpas.

    Por ahi se paso decirte mauricioniñoavella .

    Cada una de mis redes tiene DHCP y fisicamente estan separadas, cada una con su respectivo switch.

    Espero estemos hablando de la misma topologia eee?

    Y las pruebas las hice con thunderbird, solo falta hacerlo con outlook.

    Saludos!!!



  • ¡Hola!

    Problema quizás relacionado con calidad de las placas de red y/o su MTU.

    Buscando en Google:

    mail attached site:forum.pfsense.org

    se llega a:

    http://forum.pfsense.org/index.php?topic=15177.msg94941
    http://forum.pfsense.org/index.php/topic,11735.0.html

    Me dió por buscar también con Google:

    smtp mtu outlook

    y ¡eureka! Un montón de información …

    Especialmente interesante me resultó http://help.expedient.com/broadband/mtu.shtml

    28-abril-2015. Moderador. Página no disponible. Véase:
    http://muzso.hu/2009/05/17/how-to-determine-the-proper-mtu-size-with-icmp-pings

    y con ping pude ver que, desde casa (con un WinXP detrás de un router ADSL) mi MTU no va más allá de 1464:

    ping www.dominio_de_prueba.extension -f -l 1464 
    

    Y con un Unix/Linux:

    ping -M do -s 1464 www.dominio_de_prueba.extension
    

    En la configuración de las interfases de pfSense puede alterarse el MTU por defecto, que es de 1492 o 1500.

    El MTU es negociado entre origen y destino pero a veces esa negociación no se realiza de forma adecuada. Testear con ping cuál es el MTU y probar cambiándolo en las interfases de pfSense (ver imagen).

    http://es.wikipedia.org/wiki/Unidad_máxima_de_transferencia

    Asegurarse también de estar con última versión de pfSense …

    Saludos,

    Josep Pujadas




  • ¡Hola de nuevo!

    En el trabajo, detrás de un pfSense 1.2.3 mi MTU puede ser como máximo 1472

    Por lo que he leído, si los equipos funcionan correctamente son capaces de ajustarlo ...

    Algunas tarjetas de red dan problemas con esto. Si rebajando el MTU en las interfases de pfSense sigue sin funcionar, probad a cambiar las tarjetas de red.

    En el libro de pfSense dicen que mejor evitar los chips de Realtek. Son chips baratos empleados por muchos fabricantes y el problema no es el chip, más bien la disparidad de implantaciones que hay.

    Si en Google se pone avoid realtek site:pfsense.org realtekmente salen muchas páginas.

    Decir que mis pfSense y muchos equipos que tengo llevan Realtek y no he tenido problemas al respecto.

    Saludos,

    Josep Pujadas



  • muchas gracias atodos y en especial a jose

    efectivamente el problema era este una  tarjetas de red MTU

    problema solucionado

    gracias y mil gracias


Locked