The Path is too deep when Filtering is on and extremely slow (SOLVED)

  • Hello

    I'm busy trying to set up pfsense in my network but am running into a little issue when coping files from the LAN to my file server when filtering is turned on. I'm getting an error "The Path is too deep" when I try to copy files to the file server. Also, just simply browsing the folder structure on the server is extreme slow but again only when filtering is enabled.

    LAN IP:
    WAN IP: (Connects to DSL load balancer appliance)
    OPT1 IP (Locally hosted Servers):

    I have a mail server, Web server and File Server hosted on the OPT1 interface.

    If I turn filtering off everything runs smoothly. I've even tried creating allow all rules on all interfaces and so on but still experiencing the same issues.

    Is there something that I've missed? Also, is there not a way to disable filtering on the OPT1 interface only?

    Thanks for the assistance.

  • I came across this site:

    It's says that I might need to increase my max window size

    To make the command survive a reboot:

    1. On Linux or SecurePlatform, edit the $FWDIR/boot/modules/fwkern.conf file using vi.
      2. Set a parameter name to a value, e.g.,
      3. Run the fw ctl get int fwtcpstr_max_window command to verify whether the new value is applied on the OS properly.

    Any ideas on how to try this on pfsense?

  • Solved this by disabling Automatic outbound NAT and created my own outbound NAT rules. Solved my speed issues as well as the "The Path is too deep" error.

Log in to reply