Impossible d'envoyer un mail



  • Bonjour,
    J'ai un Lan d'une 30ene de machines, mon pfsense est en bridge avec ip fixe.
    Le problème est que les clients de la messagerie n'arrivent pas à envoyer les emails (serveur chez un isp au usa); j'ai cette erreur ( Too many smtp conncetion from monipfixe..).
    Si je laisse uniquement mon router 3com, tout marche bien, une fois mon fw connecter entre mon router et mon lan, tout coince.

    Merci



  • C'est vraisemblablement un problème qui vient de votre serveur mail… 
    J'augmenterais le nombre de connexion simultanées autorisées par défaut sur le serveur, ou dans le cas d'utilisation de postfix, j'inclurais votre IP publique dans le paramètre "mynetwork".

    De mon point de vue cela n'a rien à voir avec pfSense.



  • Je pense aussi que Pfsense n'est pas en cause dans le problème rencontré.



  • Le pfSense n'est pas en cause ?

    Tel que décrit, cela semble pourtant le cas !

    Or il ne semble pas que pfSense puisse produire un tel message !
    Il est assez incompréhensible qu'un pfSense, selon qu'il soit présent ou non entre les PC et le routeur, provoque un tel résultat.
    En quoi, pfSense pourrait générer des sessions smtp supplémentaires (et excessives) ?

    Si le problème n'est pas clair, il est une chose claire, c'est que le problème est … mal décrit :

    • où sont les adressages ?
    • quelle justification du mode bridge ?
    • quels règles de LAN vers WAN ?
    • quels packages installés sur pfSense ?
    • quels types de connexions smtp ?
    • quel nombre des sessions smtp simultanées ?

    S'il y a une règle d'autorisation de trafic smtp, il est évident qu'il faut les loguer et regarder, un, les logs, deux les états de liaison (states).

    NB : Je ne comprends guère l'intérêt de mettre un pfSense en bridge : une fois qu'est acté de mettre un firewall, la logique est de changer l'adresse ip du routeur et de bien mettre le firewall en routeur NAT.

    NB : nul besoin de conseil pour Postfix, il n'y a pas de serveurs de messagerie interne. De plus cela semble le smtp du fai qui envoie le message d'erreur ! Sur un serveur interne, je ne mettrais jamais une @ip publique dans mynetwork.



  • NB : nul besoin de conseil pour Postfix, il n'y a pas de serveurs de messagerie interne. De plus cela semble le smtp du fai qui envoie le message d'erreur ! Sur un serveur interne, je ne mettrais jamais une @ip publique dans mynetwork.

    Ah bon… C'est pourtant la manière la plus simple de résoudre le problème de notre ami… 
    Si le fait d'inclure l'IP publique du réseau dans le paramètre "mynetwork" résout le problème c'est que le problème vient de la configuration du serveur mail…

    Il n'y a aucune (si le réseau est bien maintenu) de ne pas inclure l'IP du réseau distant dans ce paramètre.

    mynetworks (default: see "postconf -d" output)
    The list of "trusted" SMTP clients that have more privileges than "strangers".

    In particular, "trusted" SMTP clients are allowed to relay mail through Postfix. See the smtpd_recipient_restrictions parameter description in the postconf(5) manual.

    You can specify the list of "trusted" network addresses by hand or you can let Postfix do it for you (which is the default). See the description of the mynetworks_style parameter for more information.



  • @gregober :

    • mynetworks :

    Je peux me tromper mais "mynetworks" permet de désigner l'origine des machines dont le serveur mail accepte de relayer les mails (pour toutes destinations : pas seulement ceux gérés par le serveur : "mydestination" ou "relay domains" ou "virtual alias domains").

    En clair,

    • un, le courrier est accepté, quelque soit l'adresse ip, si le courrier est à destination des domaines que gère le serveur ("mydestination" …),
    • deux, le courrier est accepté, pour les adresses indiquées dans "mynetworks", pour les domaines gérés mais aussi les autres.

    En quoi l'adresse publique aurait besoin d'être dans "mynetworks" ? En rien !
    Un serveur Postfix, dans un réseau interne, peut avoir dans "mynetworks" le réseau dans lequel il est.
    Un serveur Postfix, dans une dmz, pourra avoir le reseau Lan et le réseau DMZ (s'il y a des hôtes qui doivent envoyer des mails).
    Mais, l'adresse ip public (externe) n'a nul besoin d'être dans "mynetworks".

    Enfin, moi, je ne mets QUE ce qui est nécessaire dans "mynetworks" dans les serveurs internes que je gère.

    Tu raisonnes (peut-être) sur le smtp du fai ... sur lequel ce qui est nécessaire est (forcément) déjà fait ! (Et sur lequel il parait impossible de faire quoi que ce soit !)

    • contexte du fil d'origine :

    Il n'y a pas de serveur de mail interne. Il est mentionné seulement "serveur de l'ISP" comme si les connexions n'était que des smtp sortants de clients.
    Je vois mal demander au FAI d'augmenter le nombre de connexions smtp entrantes simultanées !

    Mais il y a forcément quelque chose d'incompris compte-tenu de la présentation ne précisant rien du tout (sans compter une config en bridge inutile) ...
    Je pense plutôt au package "spamd" incompris (et inutile puisque destiné au trafic smtp entrant d'après ce que je comprends).

    Mais faute d'informations ... 
    (La question ne doit pas être très importante puisque le problème n'est pas relancé et puisqu'il n'y a presque pas d'informations !)


Locked