Redirect



  • Hello
    I have a problem with URL redirection to my Portal page (http://mycaptiveportal:8000) after session timeout (radius auth). There is no alert about session timeout, thats why users are in trouble, when all internet stops and they cant browse internet.

    Is there some solutions or some workaround?
    Thanks



  • @mpurins:

    Hello
    I have a problem with URL redirection to my Portal page (http://mycaptiveportal:8000) after session timeout (radius auth). There is no alert about session timeout, thats why users are in trouble, when all internet stops and they cant browse internet.

    Is there some solutions or some workaround?
    Thanks

    Do you have the popup enabled?



  • yes.



  • most browsers block the popups



  • m0n0wall 1.21's captive portal has been merged into beta2.



  • @jeroen234:

    most browsers block the popups

    Why not explaining on your main Portal web page that users should/could use IE->Utils->Blocking popup windows->Parameters to block publicity-> [[b]add the opt1 IP : i.e. 192.168.2.1] so they would receive a 'disconnect' windows, from pFsense only.

    By the way, pFSense & FreeRadius (a windows server process) rocks….. But don't look for time limited features in it - it isn't any great use if prepaid functionality is needed.



  • @Gertjan:

    @jeroen234:

    most browsers block the popups

    Why not explaining on your main Portal web page that users should/could use IE->Utils->Blocking popup windows->Parameters to block publicity-> [[b]add the opt1 IP : i.e. 192.168.2.1] so they would receive a 'disconnect' windows, from pFsense only.

    there are more browsers then just that crapy thing microsoft delivers
    this way you have to explan it 15 or more times for all the browers



  • @Gertjan:

    @jeroen234:

    most browsers block the popups

    Why not explaining on your main Portal web page that users should/could use IE->Utils->Blocking popup windows->Parameters to block publicity-> [[b]add the opt1 IP : i.e. 192.168.2.1] so they would receive a 'disconnect' windows, from pFsense only.

    That wouldn't work, as depending on which page the user tried to access the captive portal popup page appears to be from that side and not the pfSense. Try going to google.com when not authenticated. you would have to allow popups from google. next time you hit it by going to myfavouritesite.org and you would have to enable popups from that site…doesn't work. I would rather like to see a single line small frame at the top of the next page after authentication to give the user the possibility to click "open logout popup" along with a note as most browsers allow the popup when the user clicked on it.


Locked