Problemas al Descargar Drivers desde HP.com



  • Hola, este es mi primer post, les comento la situacion, acabo de implementar pfsense como la solucion definitiva al problema de red que teniamos en la dependencia de gobierno donde trabajo, aqui tenemos una conexion a la WAN del Gobierno de mi Estado, y otra conexion a un proveedor de internet, e usado pfsene para repartir la asignacion de puertos de mi LAN entre estas dos salidas a internet, ambas tienen conectividad a la pagina de HP.com y se puede descargar drivers y demas desde cada red independientemente.

    El problema surge cuando intento descargar drivers desde una pagina ejemplo hp.com (es con la unica pagina que lo e constatado), llego corectamente hasta la parte donde esta el vinculo para descargar, doy clic en el vinculo .exe o .zip y en firefox me aparece la ventana de descargas, con el elemento listo para descargar pero con 0 kb de avance, con IE solo aparece que la pagina a tardado mucho en responder, esto me pasa siempre que aparece que va a descargar desde un servdidor ftp de hp, las escasas veces que maneja descarga desde un servidor http si funciona.

    Mas sin embargo si configuro un virtual ip de cualquiera de las subredes de mis salidas, y la asigno a alguna de las ips de mi LAN funciona perfectamente, aunque a veces tarda un poco.

    La verdad no he verificado si falla en otros sitios aunque creo que si, ej el sitio de actualizacion del Antivir la parecer tampoco descarga correctamente






  • Me huele a que el problema esta en el "FTP-proxy", en mi caso tengo este modulo habilitado solo en la LAN, la WAN lo tiene deshabilitado.
      Tu como los tienes?

    Estos los localizas en la pantalla donde configuras tus NIC's.

    Si haces un ftp a cualquier sitio funciona, como ftp.freebsd.org?

    Saludos!!!



  • Como tu me comentaste, verifique el proxy FTP en mis interfaces,

    LAN;  Desmarcada Disable the userland FTP-Proxy application 
    WAN;  Marcada Disable the userland FTP-Proxy application 
    ADSL;  MArcada Disable the userland FTP-Proxy application

    yo no me puedo conectar pero otras maquinas si se pueden conectar a servicios FTP en cualquiera de las 2 interfaces y de hecho no me pude conectar a la pagina ftp://ftp.freebsd.org/ ni via web ni via cliente FTP.

    Crees que sea algun otro tipo de problema?



  • Tienes habilitado el squid?
    Ya probaste desmarcando todas las casillas de ftp proxy helper?



  • No no tengo habilitado el Squid, ya deshabilite  la casilla Disable the userland FTP-Proxy application  a todas las interfaces y aun no funciona, dime es necesario reinciar el pfsense para que aplique este tipo de configuraciones???

    El problema a final de cuentas es el puerto ftp no?

    Cree una regla hacia el puerto FTP y la puse hasta el inicio pero ni asi funciona.

    Tengo otros servicios activos
    DNS forwarder
    DHCP server
    Avahi
    SNMP
    desinstale el NTOP pues tuvo un error de instalacion y despues de funcionamiento, cren que esto ocasiones esto, planeo reinstalarlo

    Afectaran estos servicios?
    Tengo esto en la parte de Services

    avahi Not available.
    Stopped
    [Start Service]
    dnsmasq DNS Forwarder
    Running
    [Restart Service] [Stop Service]
    ntpd NTP clock sync
    Running
    [Restart Service] [Stop Service]
    dhcpd DHCP Service
    Running
    [Restart Service] [Stop Service]
    bsnmpd SNMP Service
    Running



  • ¡Hola!

    No no tengo habilitado el Squid, ya deshabilite  la casilla Disable the userland FTP-Proxy application  a todas las interfaces y aun no funciona, dime es necesario reinciar el pfsense para que aplique este tipo de configuraciones???

    Sólo necesitas la casilla desactivada en la LAN, donde haya clientes que hagan FTP.

    A parte de esto tienes que tener autorizado el tráfico TCP con destino al puerto 21.
    Sólo necesario en versiones antiguas.

    No creo que los paquetes añadidos afecten a esto.

    Supongo que estarás con una última versión 1.2.3…

    Saludos,

    Josep Pujadas



  • bellera.

    A parte de esto tienes que tener autorizado el tráfico TCP con destino al puerto 21.

    No es necesario esto, yo nunca he necesitado abrir la regla para el protocolo ftp, si revisas las reglas cuando habilitas el ftp-proxy pfsense automaticamente agrega esa regla. Checalo, hasta desde el cmd del windows me funciona el ftp, y lo comento por que yo soy de los que abro solo los puertos necesarios no + no -, si estoy mal de favor corregirme, pero asi me ha funcionado a mi.

    Cuando hagas los cambios para habilitar o deshabilitar el ftp-proxy reinicia el pfsense ya que me he tocado hacerlo para que los cambios sean aplicados, no deberia pero la practica me ha dicho esto.

    yo no me puedo conectar pero otras maquinas si se pueden conectar a servicios FTP en cualquiera de las 2 interfaces

    A quien te refieres con esto de "YO"?

    Cree una regla hacia el puerto FTP y la puse hasta el inicio pero ni asi funciona.

    Cuando esta probando, tus logs del firewall te lo van a decir si existe o no bloqueo, lo dicen?

    Animo!!!



  • Periko,

    ¡Entono el mea culpa! La regla para el puerto 21 era necesaria en versiones antiguas. Por eso le decía al compañero que suponía que estaba con una versión actual …

    Lo del reinicio es un buen apunte. En versiones nuevas no he tenido la necesidad de hacerlo, al tocar FTP-Proxy. En las antiguas, sí...

    Si un PC en concreto no puede conectarse igual tiene un cortafuegos local (en el PC) con reglas erróneas...

    Saludos,

    Josep Pujadas



  • Asi es bellera, aun no confirma eso de

    YO

    estaba pensan lo mismo, que algo local en su maquina local le este causando esto, ya que menciona que

    los demas

    no tienen problemas, no tiene proxy que le moleste, entonces ahora sigue si su equipo, debe haber tiene algo por ahi, Guindous o Linux tienen por default el firewall bloqueando todo o los mentados antivirus que maneja los guidous bloquean todo.

    Si todos los demas estan bajo la misma red y pasa todo atravez del pfsense todo apunta a su equipo es el problema, ya que las mismas reglas son para todos.

    Saludos!!!



  • hola señores, gracias por responder, eso del YO es un error que no habia verificado, mi maquina junto con todas las maquinas de la dependencia tienen el mismo problema, las unicas maquinas que pueden descargar desde FTP son aquellas que tiene configurada una Virtual IP y estan vinculadas en el NAT como les muestro en la imagen, solo de esta manera logre que estas maquinas pudisesen acceder al FTP.

    Voy a tomar, el primer paso actualizando a la version 1.2.3, ya que tengo la 1.2.2, solo espero que con ello se solucione el problema, tengo la casilla Disable the userland FTP-Proxy application  activada en 2 interfaces menos en la que corresponde a la LAN.




  • Bueno al parecer la actualizacion al pfsense 1.2.3 a funcionado como deberia, con ella ya tengo acceso a las descargas FTP de diversos sitios, sin necesidad de ponerlos en el NAT.

    Muchas Gracias a todos.

    Les comento, cuando aun estaba en la version 1.2.2 iba a aplicar una Regla en la LAN que permitiera todo el trafico hacia 127.0.0.1 port 8010-8030 me parece, como parte de la solucion que proponia una FAQ de pfsense. La aplique y no funciono, de cualquier forma la quite y actualice a 1.2.3 y problema resuelto


Locked