Captive Portal - No redirect



  • i'm having a battle with this on an alix with 4 vlans on vr2. try as i may, i just can't get it going. i can go to http://pfsense_ip:8000 and the page is there but no redirect occurs.
    tried all i can, even got the xml error when deleting vlans and had to rewrite the conf/config.xml to get the thing back up and running. i've noticed if i try and restart the captive portal service, it crashes the web configurator and the only way to get it back is via the console.
    i'm just wondering whether it was anything to do with the intial config as i selected no vlans and then added them later. however, i no longer use the lan interface (vr1) and the vlans are on vr2.
    tried the suggested dns, gateway resolutions etc on here but all to no avail. this is 1.2.3-RELEASE (dec 7 2009)



  • i have the same issues on my nsa-1041 with 1.2.3 release.

    portal is shown, login is ok and registered in the captive portal status but no redirect. Restarting the captive portal service will crash the WebGUI. Captive portal is also configured on a vlan.
    Additionaly i have a carp cluster. On testing the captive portal i see the login page only if i connect to the real interface ip. if i use the virtual ip I will get a timeout.

    @louis-m: do you also have a carp cluster?



  • in my case: (1.2.3) captive portal + squid in trasparent mode, when the captive portal stops to working I must stop and restart squid.
    The reboot of the pfsense doesn't fix the problem.
    It seems that something inside squid stop to working, but I don't know what.
    The strange thing is that if I turn off the captive portal, clients can browse the internet through the squid.

    Giacomo



  • instead of putting "www.domain.com" in redirect input box, just typein "http://www.domain.com" take note with the "http://".

    HTH



  • Through much testing I found the error.

    This was caused by the default gateway in the final rule.
    The default gateway must be "default". if you use any other gateway (directly or balancer) it will not work and react as described above.


Locked