Intra-BSS communication not working



  • WRAP with an EMP8602 running 1.0-SNAPSHOT-09-27-06 embedded.
    I have the allow intra-BSS communication option set and the WLAN is configured as AP.  I have a rule to allow WLAN subnet –-> any.  I am unable to ping from one wireless client to another though both clients can ping the router.  Any ideas?



  • I just tested this and it somehow looks like other protocols are working but icmp between the wlanclients is borked. This however is a freebsd driver issue. Can you test other protocols? I tested with vnc for example.



  • I tested some other services as requested, none worked.
    ssh: failed
    afp: failed
    remote desktop (vnc): failed

    If I connect the server to the wired network everything works.

    Where can I look via the shell to see if intra-BSS is actually being enabled on the wlan card or not?



  • We already debugged that. It's enabled. It's a driver issue. We can't do anything about it besides waiting for a new driver. It has to be fixed in the driver.



  • This looks like a 'feature' that I was looking for longtime.
    In your case, you want the WLAN clients to cummunicate with each other. This has to be implemented into the the driver of the EMP8602, as already steated.
    The driver, in your case, must behave as a switch between all wireless connected clients.

    If you can't wait for a driver fix - remove it, use another Enternet interface card - hook up a classic AP (Linksys, Netgear, you name it) to it and of you go. These AP's all have an option in their settings list, named "Client Isolation" - this is the one that you want to turn off.

    Drop in overhere to see the opposed point of view:
    http://forum.pfsense.org/index.php/topic,1268.msg7666.html#msg7666



  • Is the "Allow Intra-BSS" setting removed from 1.0 version? I have a Atheros card set up on OPT1 as a AP but i can't find  the setting
    to allow intra-bss communication. What I'm I doing wrong?



  • It was hidden for version 1.0 as it was reported broken, so clients are for now always seperated: http://cvstrac.pfsense.com/chngview?cn=14890

    Once it is fixed in the atheros driver we'll unhide it again.



  • @hoba:

    It was hidden for version 1.0 as it was reported broken, so clients are for now always seperated: http://cvstrac.pfsense.com/chngview?cn=14890

    Once it is fixed in the atheros driver we'll unhide it again.

    I see. Is there any possibility to enable it from the console?



  • If you want to unhide it from the gui just remove the two highlighted green lines from the file ( http://cvstrac.pfsense.com/chngview?cn=14890 ) by using diagnostics>edit but it won't work. That's why it was hidden. It's not a pfSense bug but a driver bug in freebsd.



  • @hoba:

    If you want to unhide it from the gui just remove the two highlighted green lines from the file ( http://cvstrac.pfsense.com/chngview?cn=14890 ) by using diagnostics>edit but it won't work. That's why it was hidden. It's not a pfSense bug but a driver bug in freebsd.

    Thanks a lot !! I unhided the setting and enabled it and as far as i can tell it works for me.


Log in to reply